PDA

View Full Version : App from promo code didn't download!


gekkota
12-21-2009, 03:31 PM
I won a promo code, typed it in, the box that asks for my password appeared and I typed it in...then nothing. No spinning little wheel, no icon in my app folder, nothing! :(
I got an email receipt from iTunes as usual--so iTunes thinks I have purchased the game, only it never downloaded at all. Suggestions? (I tried the "report a problem" but I think that complaint just gets sucked into a big, black hole.)
Thanks.

The Bat Outta Hell
12-21-2009, 03:32 PM
Have you tried redownloading it?

It'll most likely say you can download it for free.

drelbs
12-21-2009, 03:33 PM
1) Try the code again.

2) in iTunes, click Store -> Check for available downloads

3) Try rating the app in iTunes. If it lets you, then you already own it and can download it again for free.

le'deuche123
12-21-2009, 03:35 PM
I've had this happen, and when I reentered the code it said "this code has already been redeemed" after that I backed out and the Icon was loading on the springboard.

Kamazar
12-21-2009, 03:36 PM
Yeah, just try redownloading it. If it says you own it, you own it. Downloaded Galactic Gunners on my touch, didn't finish downloading. Synched up, it was on my computer. Don't worry, just redownload it.

Zincous
12-21-2009, 03:36 PM
In iTunes, in the upper right, click your email address to view your account. It will ask for your password.

Once you can see your account, look at the top area for "available downloads". You should see you have one waiting...

If not, just go re-download the app from itunes, should be free.

ImNoSuperMan
12-21-2009, 03:40 PM
About redownloading, always review/rate the app in iTunes before hitting that download button if you are unsure about owning it. Download it only if itunes allows you to review it.

gekkota
12-21-2009, 03:51 PM
Thanks for all the fast responses!
It worked. I'm happy now!
:)

loves2spoon
12-21-2009, 03:56 PM
I've had a couple problems with promo codes as well, sometimes they download instantly, other times it looks like iTunes starts downloading it twice. odd