Support our Sponsors:

Go Back   Touch Arcade > Other > Site Feedback and News

Reply
 
Thread Tools Display Modes
  #1  
Old 12-13-2012, 08:38 AM
Echoseven Echoseven is offline
Moderator
iPhone 4, iOS 5.x
 
Join Date: Jul 2011
Location: The red Skittle
Posts: 4,953
Default "Forums" button on front page

Pressing the "forums" button in the top bar of the front page from my iPhone 4 opens up the same link as the current sponsored app (currently the monster truck one).

Doing the same on my iPad/PC simply takes me to the forums.

Not sure what's going on there, but it's really stupid, especially on a device that force-opens the App Store for you. Hope it's unintentional and an easy fix.

Just to expand: it opens the App Store then, when I come back to Safari, it starts loading the forums with no further input from me, the same way a pop-up would behave.
Reply With Quote
  #2  
Old 12-14-2012, 11:02 AM
blakespot's Avatar
blakespot blakespot is offline
Senior Member
iPhone 4
 
Join Date: Apr 2008
Location: Alexandria, VA (USA)
Posts: 1,764
Send a message via AIM to blakespot
Default

This was unintentional and was due to a DOM tree event bubbling issue, though it's curious why it just, all of a sudden, became a problem.

At any rate, the mobile website has been adjusted in structure to avoid the issue. Please let us know if you find any ill-effects that the fix may have caused the we've not seen. Looks ok from here.

Thanks.



bp
Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright 2012, TouchArcade.com, LLC.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2008 - 2011, TouchArcade.com. Privacy Policy / DMCA Copyright Agent