IAP cannot be tested in simulator?

02-01-2013, 04:14 AM
#1
IAP cannot be tested in simulator?

Always "unknown error" when using a test user account. (The account is fresh, never used in Settings.app)

And I cannot test on device either. There's no sand-box environment. The reason may be the app has already in app store (I want to add new iaps), or the device is jailbroken. Can't be sure. Really strange.

In case you like both match-3 game & Fruit Ninja:
http://itunes.apple.com/us/app/gemania/id471333673?mt=8
02-01-2013, 02:13 PM
#2
Quote:
Originally Posted by willzeng View Post
Always "unknown error" when using a test user account. (The account is fresh, never used in Settings.app)

And I cannot test on device either. There's no sand-box environment. The reason may be the app has already in app store (I want to add new iaps), or the device is jailbroken. Can't be sure. Really strange.
On a non-JB device you do the following. A JB device I am just not sure about it.

First in iTunesConnect set up a test user. Must have a test user to go into the sandboxes for Game Center and iAP. Note: the iAPs need to be added to the app config in iTC and you should have created a new version entry in iTC but gone to "ready to upload binary" state yet.

On the device go into settings for the store and log out of the store. close all your apps that are running and reboot the device. do not log back into the store yet.

Run up the development version of your app with iap's up on the device. Select the iAP and log into when asked to using the the "Test User" you created in iTC.

Your iAP's should work then. If you have issues it could be the JB state of the device intefering with the sandbox. But I am not certain about that as I make it rule to never access the developer tools and sections with a JB device.

Also do not ever use a test user account to access the real app store. It will break the test user account most times. Hope this helps.