App description: "The combination of a quality story, good combat, tough puzzles, and amazing production values make Sacred Odyssey: Rise of Ayden well worth your time and money." - SlidetoPlay.com, 4/4.

Plunge into the most ambitious Action RPG ever released on iOS! Become Ayden, a young hero chosen by the god Uryah to save the kingdom of Lasgalen from the Apocalypse. Sacred Odyssey: Rise of Ayden is an amazing adventure in a majestic world that will fascinate you for countless hours.

Take your first steps on this epic adventure for FREE. Then, if youre ready to take up the challenge, unlock the full game through in-app purchase.
** IMPORTANT: ONCE PURCHASED, THE GAME CAN BE DELETED AND REINSTALLED FREELY ON ANY COMPATIBLE DEVICE REGISTERED TO YOUR ACCOUNT.

** Confirm that your device is compatible. This game is only compatible with 3rd and 4th generations of iPod touch (16/32/64GB) devices along with iPhone 3GS, iPhone 4 and iPad. Before downloading, please check the back of your device to make sure that it meets the system requirements.

A TIMELESS LEGEND
- The peace of the world is now being threatened. Reunite the 4 fragments of Uryahs Grail and gain supernatural powers to defeat Amonbane, the dark lord at the heart of Lasgalens suffering.
- The fight against the demonic Amonbane will mean difficult decisions for Ayden, and Princess Lyanora will help him throughout. But when the moment comes to save the world, will Ayden be ready to make the greatest sacrifice?

AN EPIC ADVENTURE IN A FANTASTIC OPEN WORLD
- Ride your horse, Miya, across the expansive plains of the kingdom and launch powerful sword strikes as you gallop through fields of enemies. Your journey will introduce you to many locations and foes.
- Defeat evil creatures in the Plains of Urvale, fend off enormous bosses in the icy Temple of Altemagus and the volcanic Firepitch Keep to ultimately face Amonbane himself in the royal halls of Kivira Castle.

ALL THE GREATNESS OF A TRUE ACTION/RPG
- Begin your journey with but a simple sword, acquiring new weapons and abilities along the way. Soon, you will wield the Sacred Shield, Locrian Hawk (boomerang), the Nagual Cobra (grappling hook) and even the platinum Gauntlet of Brakor.
- Each new piece of equipment will grant you access to new areas, new techniques and greater danger. They will even help you to overcome the many enigmas and challenges you face.

Certain apps allow you to purchase virtual items within the app and may contain third party advertisements that may redirect you to a third party site.

ImNoSuperMan's comments:

The IAP in this game works like most other games in that you buy it once, and can always unlock it later using your iTunes account information. Nothing is consumable at all. The game is free to download, but to play any more than the demo you need to pay the normal Gameloft price to access the rest of the game.

For further info and discussion about this hella confusing IAP use this thread instead please. Thanks!





Retina ScreenShot
(click to enlarge)












International version : http://itunes.apple.com/nz/app/sacred-odyssey-rise-of-ayden/id414644949?mt=8
04-03-2012, 05:33 PM
Joined: Jan 2012
Location: Philippines
Posts: 19,287
Quote:
Originally Posted by Pepper2427 View Post
For Arcadeluver. Check out page 18
Er... O_o

Exact-Psience My 2014 Top 10 Games of the Year: Monster Hunter Freedom Unite, Hearthstone, VVVVVV, Battleheart Legacy, Wayward Souls, Bug Heroes 2, Powerpuff Girls Defenders of Townsville, Deep Loot, Monument Valley, Bioshock Honorable Mentions: Traps N Gemstones, Bardbarian, Goblin Sword
04-05-2012, 03:21 PM
Hello I have a hard time in this game .. So. Get to three doors that were blocked with , broke the ice and now it's a room that the kinda bridges and three statues of fists holding bug ice crystals in their hands and I just dont know what to do , pleeeaaaaase help

04-06-2012, 08:43 AM
Help

how to take those item in the red circle??
Attached Images
File Type: jpg IMG_0005.JPG (204.8 KB, 1 views)
04-12-2012, 03:47 PM
I've gotten to this room in the Ice castle, and I haven't figured out what to do. I punched the little ball on a stand, and I didn't notice anything happen. There are a couple flying rings. Do I need to get something before I can get through this level? Thanks.




Any tips? Thanks.
04-17-2012, 05:44 PM
Quote:
Originally Posted by madcat369 View Post
RESTART the checkpoint so it you have the default settings of the blocks.
X=block 0=lava

Just hit the top right ring ONCE

it goes:

X0X
0X0
X0X
to
XXX
X00
XXX
I tried this, I don't think it works. Though I mau have the wrong top right ring. I'll keep trying it though, thanks.
06-15-2012, 06:25 PM
Fire dungeon - portal room

AS the tital suggests, I am stuck in the fire temple with the portal room and the moving staircases. I can get the left side staircase set, but I am always JUST missing the left side. Is there a way to do this? Or it it just a 'you have to persist thing'?

Nevermind I got it.

Last edited by CupidsLiver; 06-15-2012 at 07:16 PM. Reason: I youtubed it XD
06-25-2012, 11:06 PM
Spting of Niflak

I think I'm alone since noone else is trying to help me.
Well, I need help finding the Spring oc Niflak, I M totally lost as to were this is.
I need to go there to seeif they have Ayeens uncle and the Princess.
Help?!?!?!?
07-26-2012, 09:25 AM
Joined: Oct 2010
Location: North Carolina
Posts: 481
I know this is an older thread but I am having so much fun playing this game for the first time that I wanted to give it a quick bump so people saw it. On top of that, I have read the last seven or eight pages of this thread and thought it was just wonderful that there was a good RPG on the market that had us solving puzzles that actually presented some small challenge. It is quite refreshing on the super casual rpg games on the ios market. Really enjoying it!
07-27-2012, 12:15 AM
Joined: Jan 2012
Location: Philippines
Posts: 19,287
Well... i wouldnt really call this title an RPG coz it's more of an action adventure game similar to Zelda. And yes, this is one of gameloft's really good games and is one of my favorites.

Exact-Psience My 2014 Top 10 Games of the Year: Monster Hunter Freedom Unite, Hearthstone, VVVVVV, Battleheart Legacy, Wayward Souls, Bug Heroes 2, Powerpuff Girls Defenders of Townsville, Deep Loot, Monument Valley, Bioshock Honorable Mentions: Traps N Gemstones, Bardbarian, Goblin Sword
09-30-2012, 01:02 PM
Quote:
Originally Posted by play.Lilred.me View Post
Thanks! I did that at first, but after several tries I started to wonder if I needed to switch weapons. There is no health meter so I couldn't tell which weapon was working.
I've been stuck on this for over a week and I've tried everything so I know the eagle but what weapon do I need to use after that? Does it matter?

All times are GMT -5. The time now is 12:46 AM.