Support our Sponsors:

Go Back   Touch Arcade > Other > Site Feedback and News

Reply
 
Thread Tools Display Modes
  #1  
Old 05-30-2011, 05:36 PM
eisa01 eisa01 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 8
Default Update YouTube embed tag to support HTML5?

I run Safari without Flash and I noticed that the YouTube videos you embed on the front page doesn't show up. AFAICT this is because you use the old embed code, if you switch to the [url=http://apiblog.youtube.com/2010/07/new-way-to-embed-youtube-videos.html]new one[/url], clients without Flash will get the HTML5 video player if it's available.

Code:
<iframe class="youtube-player" type="text/html" width="640" height="385" src="http://www.youtube.com/embed/VIDEO_ID" frameborder="0">
</iframe>
edit: You could probably change this for the forum embed code as well

Last edited by eisa01; 05-30-2011 at 05:39 PM.. Reason: added a remark
Reply With Quote
  #2  
Old 12-08-2011, 06:57 AM
eisa01 eisa01 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 8
Default

Just bumping this as it is still a problem, and it should be a simple fix
Reply With Quote
  #3  
Old 12-08-2011, 06:19 PM
Sanuku Sanuku is online now
Senior Member
 
Join Date: Jun 2009
Posts: 11,405
Default

Could arn tell us if there is a Problem with that since i thought that it was already done month ago?
Reply With Quote
  #4  
Old 12-11-2011, 05:50 AM
eisa01 eisa01 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 8
Default

Nope, it works on iOS because there is some special code that manages YouTube embeds. If you don't have Flash installed on your Mac (no new Macs come with it preinstalled), you'll only get the "Missing plugin" error message.

arn fixed this at MacRumors, so I'm sure it'll be an easy fix for him
Attached Images
File Type: png noflash.png (39.2 KB, 2 views)
Reply With Quote
  #5  
Old 12-16-2011, 06:58 AM
ultimo ultimo is offline
Senior Member
iPod Touch (2nd Gen), OS 4.x
 
Join Date: May 2009
Posts: 3,872
Default

Oi TA Admins, Please look into this, I second this!
Reply With Quote
  #6  
Old 01-29-2012, 04:33 PM
iJay iJay is offline
Senior Member
iPod Touch (1st Gen), OS 3.x
 
Join Date: Jan 2011
Posts: 281
Default

Bump. It would be great if this could be fixed.
Reply With Quote
  #7  
Old 04-15-2012, 11:35 AM
j.dillinger j.dillinger is offline
Junior Member
iPhone 4, iOS 5.x
 
Join Date: Apr 2012
Posts: 1
Default

Please, I second this. Registering on YouTube that you only want to view HTML5 doesn't work if your cookies are removed. I'm curious, why hasn't been implement thus far?
Reply With Quote
  #8  
Old 11-17-2014, 08:21 AM
gingerbeardman gingerbeardman is offline
Member
iPhone 6, iOS 8.x
 
Join Date: Aug 2009
Location: St Ives, Cornwall & London, UK
Posts: 42
Default

Please fix this.
Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright 2012, TouchArcade.com, LLC.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2008 - 2011, TouchArcade.com. Privacy Policy / DMCA Copyright Agent