★ TouchArcade needs your help. Click here to support us on Patreon.

Devlopers please read

12-19-2012, 02:31 PM
#1
Joined: Aug 2012
Posts: 5,691
Devlopers please read

I know this is the holiday rush so this is more to earlier games but also to newer.

Please state which iPod/iPhone/iPad your game works on if it says touch 4 and people get it and it doesn't work well then its not supported so please state which it can play on in the future. I speak for people who got doped into false advertising.

I know this might come off strong and yes maybe if I update ill gladly play it and so others but if it don't work for what people have then list better like how lili and others.

Thank you to the devlopers who read this
12-19-2012, 02:39 PM
#2
Joined: Sep 2012
Posts: 141
Read it twice, still don't get it.
12-19-2012, 02:43 PM
#3
Joined: Aug 2012
Posts: 5,691
Quote:
Originally Posted by R3v View Post
Read it twice, still don't get it.
Sorry if it don't make since but I recently bought a game and said it worked for iPod touch 4 and the devlopers said it did as well but graphics weren't as impressive. Loaded it up and can't play the game at all it crashes all the time. If it doesn't work for something can't you block it for the ones it can't work on?
12-19-2012, 02:43 PM
#4
Joined: Jun 2012
Location: London, England
Posts: 842
I think he's talking about when developers say 'compatible with iPod, iPhone and iPad' on the app store, when really it only works on iPod 5, iPhone 4 and up and iPad 2 and up, so when people download it with a lower device, it doesn't work, and me, having an iPad 1, knows this is quite irritating. Especially when they feel that sticking it in tiny writing at the bottom of the description is okay, they should just have it at the side with the compatible devices.
12-19-2012, 02:45 PM
#5
Joined: Aug 2012
Posts: 5,691
Quote:
Originally Posted by AlexsIpad View Post
I think he's talking about when developers say 'compatible with iPod, iPhone and iPad' on the app store, when really it only works on iPod 5, iPhone 4 and up and iPad 2 and up, so when people download it with a lower device, it doesn't work, and me, having an iPad 1, knows this is quite irritating. Especially when they feel that sticking it in tiny writing at the bottom of the description is okay, they should just have it at the side with the compatible devices.
Yes and I know apple saying what gets supported is a lie because 3GS is always listed when that is less supported the touch 4.
12-20-2012, 01:54 AM
#6
Joined: Oct 2008
Location: Toronto Canada
Posts: 860
Quote:
Originally Posted by AlexsIpad View Post
Especially when they feel that sticking it in tiny writing at the bottom of the description is okay, they should just have it at the side with the compatible devices.
Developers can only control the text that goes in the description and "what's new" sections (and it's impossible to make any of that text tiny). The compatibility list is generated by the App Store based on info in the app bundle itself.

Unfortunately Apple doesn't allow developers to exclude specific devices via the SDK. They can only target a minimum OS version and request certain device capabilities. Older devices with 256MB of RAM are often technically "compatible" even with the strictest restrictions, but may lack the memory/power to run certain apps properly. I'd hope developers with apps that chug/crash on older devices would mention those limitations in their description - and I've seen many do just that - but sorry, you really can't expect that info to be at the top of a marketing spiel.

That said, if you've purchased an app that doesn't run on your device even after a fresh restart you should contact the developer. If they can't offer a fix then contact Apple and get a refund.

SHREDD GO FAST! FREE!
Nozoku Rush Kick Math's Ass!
Critter Panic Break yer brain! FREE!
Silverfish & Silverfish MAX Hardcore arcade insanity!
Nozoku A casual game of math & logic.
More: www.chaoticbox.com Twitter YouTube