★ TouchArcade needs your help. Click here to support us on Patreon.
06-21-2014, 04:51 PM
Joined: Apr 2009
Posts: 1,226
Quote:
Originally Posted by Glorkbot View Post
This game is freaking fantastic. It's been a while but think I'm ready to play it a second time now. (Also, it just went on sale if you haven't tried it yet.)
Agreed. It's one of my favourite all time iOS games.
06-21-2014, 10:53 PM
It's one of my all-time favorites too.

I play Glorkian Warrior because I am the Glorkian Warrior.
11-13-2014, 11:55 PM
What's up with the small screen? Is there a way to 'maximize' it?

Last edited by somedumbgamer; 11-13-2014 at 11:58 PM.
08-05-2015, 09:20 PM
Joined: Sep 2012
Posts: 3

Great game!!!
At first, this game made me sleepy, but before I realized it, I was addicted to it.
Now I have all but 1 green square. I found the ending, but I need that last square to make it work.

I was puzzled thinking this:
1. There are like 2 areas in the game that seem like I could reach them if I had a higher or double jump.
2. Skeleton said "Maybe later"
3. Second mummy is unbeatable.

So I said hmmm, that mummy can only be hiding the last square... that's the only item I don't have and he has a locked room. So unless the skeleton upgrades my jump, and then I reach that unreachable area to find a secret gun power up to be able to destroy the second mummy, then I'm totally out of ideas.

I have read in this thread that the second mummy doesn't give a green square though... which means I probably don't have to beat him. And that the skeleton gives me nothing either... that leaves me with only 1 option: to goggle view the WHOLE WORLD room by room carefully ALL OVER AGAIN.

But then I see people here talk about "red dots"... what??

Edit: After playing the PC version to be able to see the map and find just WHAT i had missed, it turns out I was missing a green square I already had acquired but died and didnt remember that i had lost it. ;___; (It was the one with the invisible staircase to the left right after coming out of the room WITH the goggles! Jeeze)

Got all red dots and got the real ending... but now I wonder. Is there a 3rd ending?........... I'm not that happy with how things ended. AND in iOS, the save file purposely erased itself and teleported me to a room that tells me "Get off my game" or something, and I have no items and cant go anywhere. I wanted to keep the save file to see the progress and record time of 15 hours....

Anyway, I loved this game. It defies the "They dont make it like they used to" quote

Last edited by jay_are; 08-08-2015 at 04:53 PM.
04-03-2016, 10:28 AM
Rebought the game yesterday for my son. We keep dying at random on the Knight boss, without getting hit by anything. Is it a glitch that's creeped in or are we doing something wrong?

I play Glorkian Warrior because I am the Glorkian Warrior.
04-22-2016, 08:41 AM
Joined: Apr 2016
Posts: 1
Great Game!

I have always been a huge fan of the Metroid series, especially the old and new 2D platforming versions. I stumbled upon this game only a few weeks ago while googling for iOS games that were similar to Metroid, and I was instantly hooked! I've been playing a little bit every day and got all the way through to the end.

End spoiler commentary/question:

The Feed Me guy is funny, but it's a little disappointing that you can't keep your file as it was before going to that final ending. What does the 0 in the upper left-hand corner mean? And why when I go to my stats page does it show all the green squares unearned again? Is there in fact a "third object collection mission" after all this? Just want to make sure I got the whole experience!

In any case, many of the pitfalls/glitches mentioned on this forum are very true and should be listened to carefully. Be sure to beat the eyeball boss before the Mummy boss and all should be fine, though! Going in this order should keep you from saving in a place you can't get back out of. If you ignore this warning, you will be stuck and have to start all over!

Also, in reference to this message and many like it:

Quote:
Originally Posted by Glorkbot View Post
Rebought the game yesterday for my son. We keep dying at random on the Knight boss, without getting hit by anything. Is it a glitch that's creeped in or are we doing something wrong?
There is DEFINITELY some sort of glitch that occurs when battling the Knight boss. I ran into this issue about 10 times while attempting to beat him. I would wait until he passed me, then jump up and shoot at him either as he was moving away or heading back toward me, well outside the window of when his laser lance appears. Then I would just hear that zapping noise as if I was hit by something or fell into lava, and then I would instantly die. No contact with anything, just instant death!

Maybe I just got lucky after awhile, but I found that I avoided triggering the glitch as long as I hugged the wall of whatever pit I was in as I was jumping out of it (in either direction). It seemed that when I jumped straight up without this extra detail, however, sometimes I would be killed. So try doing that if this issue keeps affecting you. Hopefully that helps!

Again, this game was really great overall, and I actually love the huge screen buttons designed into the interface. I never once made a mistake because of failing to hit a button that I wanted to, which was really refreshing for a touchscreen game. Too often the buttons on similar games are made too small, so you end up making way more mistakes. Perfect use of the screen real estate to give the best experience!