★ TouchArcade needs your help. Click here to support us on Patreon.
05-19-2014, 04:07 PM
Joined: Feb 2013
Posts: 29
Originally Posted by cloudpuff View Post
Anyone else having probs since the update with new levels? Mine won't load beyond the ubisoft screen anymore.
Yep, having the same issue. Sometimes gets to the title screen but freezes then crashes. Turned the phone off and on and that doesn't help.
05-19-2014, 06:06 PM
Joined: Dec 2012
Posts: 1,813
Originally Posted by cloudpuff View Post
Anyone else having probs since the update with new levels? Mine won't load beyond the ubisoft screen anymore.
Playing on Wifi (with Weblock) it usually crashes first time I open then is OK second time.

Playing on 3G, it crashes a lot more but I usually get un eventually.

Playing in airplane mode, I'm yet to see a crash.

06-04-2014, 06:05 AM
Help--I had beaten most of the game a long while ago, but after the update, I can't hover or wall run anymore????
06-04-2014, 05:12 PM
Actually, more specifically, I can't glide or wall run in ANY of the invaded levels!! ((((

I've even tried playing the first gliding level again (invaded) and I still can't even glide in it...
07-04-2014, 04:02 AM
Joined: Jul 2012
Posts: 6
That's funny. I downloaded the app via the Expedia deal last night, played two levels. And when I started the app just a few moments ago, I got 300k lums (more than you can spend!) "for my performance in Jungle Run". Well... I won't say no?

/edit: wow, it happens anytime I start the app.

Anybody experience something similar?

Last edited by Harti; 07-04-2014 at 04:05 AM.
07-14-2014, 10:28 AM
Joined: Jul 2014
Posts: 1
I got this from the Expedia deal too, and I loved Jungle Run. I had been enjoying this quite a bit and got the crowns on all the regular levels, but now that I'm playing through some of the invaded levels--I started with the candy ones--I'm having some very serious control issues. Occasionally he'll keep gliding up even when I'm not touching the screen (in Candy invaded 5 this usually means death). Normally if I hold glide while punching in the air, he'll glide once the attack is complete, and now sometimes he will and sometimes he won't. This is pretty frustrating.

I can't complain too much for a game I got for free, and I was having a great time up to this point, but now I'm fighting inconsistent controls and it is quickly sucking out the fun. Anyone else experiencing this and any chance of a fix?
06-29-2015, 08:16 PM
Joined: Jun 2010
Location: a[V-O-I-D]
Posts: 13,906
Send a message via MSN to syntheticvoid
Is anyone able to download any of the newer levels or modes? I just reinstalled this... my iCloud didn't carry over so I had to start from scratch. But now I can't get any post-release level/mode downloads.

I'm on an iPhone 5, iOS 7.1.2 - not jailbroken... I tried shutting off my ad blocker - switching over to my phone carrier data instead of wifi - resetting my phone - resetting my router...

no clues what I can do now other than hope someone knows a workaround or... anything... =o/
06-29-2015, 09:48 PM
Joined: Oct 2011
Location: NYC suburbs (New Jersey)
Posts: 1,123
Sometimes I get the automated notification to "Update for a brand new adventure". The only significant update was in May of 2014 when 16 new levels were added. I hope that helps.