★ TouchArcade needs your help. Click here to support us on Patreon.

iPhone: fearr

11-07-2008, 04:20 PM
#1
Joined: Aug 2008
Location: Canada, ON
Posts: 76
fearr

im allways scared when i buy an app and forget to check if its compatibe with first gen ipod touch.. (i hav one of those oh shit moments)................why cant developers just make all apps compatible for both generations..
11-07-2008, 04:24 PM
#2
Joined: Oct 2008
Location: California
Posts: 63
i agree
and it so hard to talk to developers
you almost have to resort to leaving a nasty review and threaten them to change it, esp. if you paid for it, so you can change your review
11-07-2008, 05:44 PM
#3
I develop for the first generation ipod touch. My thinking is that if it works on that it will work on all. The only reason I would develop with any other device is if I needed features only available on that device (i.e. camera on iphone). I guess it would all depend on the features of the app though. Not sure what the second gen itouch offers that the first doesn't besides speakers and ergonomic updates.

kwigbo.com - iPhone dev blog with code snippets and more.
----------------------------------------------------------------------------
iReviewFail.com Funny reviews from the iOS App Store
11-07-2008, 11:09 PM
#4
Joined: Aug 2008
Posts: 160
Quote:
Originally Posted by kwigbo View Post
I develop for the first generation ipod touch. My thinking is that if it works on that it will work on all. The only reason I would develop with any other device is if I needed features only available on that device (i.e. camera on iphone). I guess it would all depend on the features of the app though. Not sure what the second gen itouch offers that the first doesn't besides speakers and ergonomic updates.
yeah i don't see why guitar rock tour can't be for first gen ipod touch (and second too)