★ TouchArcade needs your help. Click here to support us on Patreon.

Ant Raid (iPad exclusive) - $2.99 -> $0.99 for the rest of this week ONLY

09-29-2011, 01:53 PM
#1
Joined: Feb 2011
Location: Tampere
Posts: 64
Ant Raid (iPad exclusive) - $2.99 -> $0.99 for the rest of this week ONLY

Ant Raid is NOW on $0.99 sale, this weekend ONLY! (until Sunday night)
The sale celebrates version 1.2.0. The default price of Ant Raid is $2.99.




Gameplay trailer:


Cinematic trailer:



More discussion on Ant Raid here:
http://forums.toucharcade.com/showthread.php?t=99744

Prank Ltd. - a game development studio.
www.prankentertainment.com

Last edited by Prank Ltd.; 09-29-2011 at 01:58 PM.
09-29-2011, 02:25 PM
#2
Joined: Jun 2011
Posts: 555
Jumped on it as soon as it showed up through AppShopper. Now I'll see what all the praise was about

09-29-2011, 04:57 PM
#3
Joined: Mar 2011
Posts: 1,049
Highly recommended for every iPad owner. A very polished and fun game, one of the few games that often really made me smile. A great deal at this price.
09-29-2011, 05:27 PM
#4
Joined: Mar 2011
Posts: 997
Prank, any chance you can lower the minimum firmware requirement to 4.2? Game looks phenomenal but I am stuck on 4.2.1.

Now playing: Squids, Shantae, Mage Gauntlet, Roboto, Emberwind, Cordy, Whale Trail, Aquaria, Super Crossfire, Extraction, Crazy Hedgy, Terra Noctis, Pocket RPG, Glowfish, Steambirds, Edge Ex, SANDWICHES!!, Goat Up, Bean's Quest, Last Rocket, Blobster, Run Jump Kill, Don't Run WAPS, Jap Werewolf, Space Tripper, Sonic CD, Sleepy Jack.
09-30-2011, 04:15 AM
#5
Joined: Feb 2011
Location: Tampere
Posts: 64
Quote:
Originally Posted by caanerud View Post
Prank, any chance you can lower the minimum firmware requirement to 4.2? Game looks phenomenal but I am stuck on 4.2.1.
Unfortunately we don't have any control over the supported firmware info. It used to be 4.2, but since we updated our dev tools, it automatically changed to 4.3.

However, there should be absolutely no reason whatsoever why Ant Raid wouldn't work on 4.2 firmware. Have you tried downloading the game, or does App Store prevent it completely from you, due to your older firmware?

Prank Ltd. - a game development studio.
www.prankentertainment.com
09-30-2011, 05:49 AM
#6
Joined: Mar 2011
Posts: 997
Quote:
Originally Posted by Prank Ltd. View Post
Unfortunately we don't have any control over the supported firmware info. It used to be 4.2, but since we updated our dev tools, it automatically changed to 4.3.

However, there should be absolutely no reason whatsoever why Ant Raid wouldn't work on 4.2 firmware. Have you tried downloading the game, or does App Store prevent it completely from you, due to your older firmware?
It will allow me to download it, but once downloaded it'll say that the game will be available once I sync my device with iTunes (assuming I will update my firmware when I do so).

Now playing: Squids, Shantae, Mage Gauntlet, Roboto, Emberwind, Cordy, Whale Trail, Aquaria, Super Crossfire, Extraction, Crazy Hedgy, Terra Noctis, Pocket RPG, Glowfish, Steambirds, Edge Ex, SANDWICHES!!, Goat Up, Bean's Quest, Last Rocket, Blobster, Run Jump Kill, Don't Run WAPS, Jap Werewolf, Space Tripper, Sonic CD, Sleepy Jack.
09-30-2011, 06:16 AM
#7
Joined: Feb 2011
Location: Tampere
Posts: 64
Quote:
Originally Posted by caanerud View Post
It will allow me to download it, but once downloaded it'll say that the game will be available once I sync my device with iTunes (assuming I will update my firmware when I do so).
Did you buy it directly with the iPad, or through iTunes with a computer? I assume it's the latter one.

iTunes always asks if you want to install the latest firmware or not when you plug the iPad in. You should be able to sync your apps without having to upgrade the firmware of the device.

Prank Ltd. - a game development studio.
www.prankentertainment.com
09-30-2011, 09:45 AM
#8
Joined: Mar 2011
Posts: 997
Quote:
Originally Posted by Prank Ltd. View Post
Did you buy it directly with the iPad, or through iTunes with a computer? I assume it's the latter one.

iTunes always asks if you want to install the latest firmware or not when you plug the iPad in. You should be able to sync your apps without having to upgrade the firmware of the device.
Directly through my iPad. The app will disappear once downloaded through my iPad if the firmware required is higher than I have installed.

Now playing: Squids, Shantae, Mage Gauntlet, Roboto, Emberwind, Cordy, Whale Trail, Aquaria, Super Crossfire, Extraction, Crazy Hedgy, Terra Noctis, Pocket RPG, Glowfish, Steambirds, Edge Ex, SANDWICHES!!, Goat Up, Bean's Quest, Last Rocket, Blobster, Run Jump Kill, Don't Run WAPS, Jap Werewolf, Space Tripper, Sonic CD, Sleepy Jack.
10-01-2011, 03:19 AM
#9
Joined: Feb 2011
Location: Tampere
Posts: 64
Quote:
Originally Posted by caanerud View Post
Directly through my iPad. The app will disappear once downloaded through my iPad if the firmware required is higher than I have installed.
That is really weird and unfortunate
Is there any particular reason why you can't upgrade your firmware? To developers it's less risky to support the latest firmware compared to older ones, as majority of customers use the latest firmware Apple has provided. When we had 4.2 in the sidebar, some users were afraid it's an outdated app that won't work on their newer firmware, so it's kind of tricky topic :/

Prank Ltd. - a game development studio.
www.prankentertainment.com

Last edited by Prank Ltd.; 10-01-2011 at 03:32 AM.
10-01-2011, 06:50 AM
#10
Joined: Mar 2011
Posts: 997
Understood. It's because I have a jailbreak that let's me use apps like Retinapad and emulators (I'm a sucker for classic games). I should be able to update to 4.3 without too much trouble, but the last time I tried it didn't work and I spent a day or so trying to fix everything (and thought I bricked my device in the process).

Not your problem, though! Good luck with sales.

FYI. I thought that requiring a higher firmware would actually mean you get less downloads because of people like me who can't play the game. I've never heard of anyone thinking that a lower firmware requirement would make people think your game was outdated. I bought Qubit once that dev lowered theirs due to numerous requests of this forum.

Now playing: Squids, Shantae, Mage Gauntlet, Roboto, Emberwind, Cordy, Whale Trail, Aquaria, Super Crossfire, Extraction, Crazy Hedgy, Terra Noctis, Pocket RPG, Glowfish, Steambirds, Edge Ex, SANDWICHES!!, Goat Up, Bean's Quest, Last Rocket, Blobster, Run Jump Kill, Don't Run WAPS, Jap Werewolf, Space Tripper, Sonic CD, Sleepy Jack.

Last edited by caanerud; 10-01-2011 at 06:53 AM.