★ TouchArcade needs your help. Click here to support us on Patreon.

iOS 4.3 and up required for all new games?

11-03-2011, 10:20 AM
#1
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
iOS 4.3 and up required for all new games?

Not a dev, but thought this would be the best place for this question.

I've read from the dev of Sad Robot, that the latest SDK from Apple requires that games have to be built with a 4.3 iOS requirement and above.

First of all, is this true?

Secondly, can you still publish games with the old SDK?

As an owner of a 2nd Gen iPod Touch, who probably won't be able to upgrade any time soon, I was just curious if Apple is forcing the hands of devs to only support iOS 4.3 and up --- thus ruling out older devices by default. 4.2.1 is the highest a 2nd Gen iPod Touch can go.
11-03-2011, 10:35 AM
#2
Quote:
Originally Posted by awp69 View Post
Not a dev, but thought this would be the best place for this question.

I've read from the dev of Sad Robot, that the latest SDK from Apple requires that games have to be built with a 4.3 iOS requirement and above.

First of all, is this true?

Secondly, can you still publish games with the old SDK?

As an owner of a 2nd Gen iPod Touch, who probably won't be able to upgrade any time soon, I was just curious if Apple is forcing the hands of devs to only support iOS 4.3 and up --- thus ruling out older devices by default. 4.2.1 is the highest a 2nd Gen iPod Touch can go.
--Edit--Things below this line are from a discussion I misunderstood -- Do not take it as truth --


I'm not the dev on our team but I we talked about that in the room here. My understanding is by default iOS 4.3 and up is required, and even just changing the setting lower doesn't lower the requirements, however there are workarounds they can do to allow the app to be used.

But this adds dev time and more testing. Be prepared for a lot of people just to require 4.3

Looking for a writer? PM me

Game Designer of:
Family Feud Matches Gaming with a side of Matchmaking!
Family Feud 2 My First Huge Apple Feature!
Pickpawcket
And more!

Last edited by Blackharon; 11-03-2011 at 11:23 AM.

11-03-2011, 10:37 AM
#3
Joined: May 2010
Posts: 9,382
Oh crap. That's not good! I have a 2nd gen too!

Currently Enjoying: BUG HEROES 2
Quote:
Originally Posted by JBRUU View Post
Ninny speaks the truth.
11-03-2011, 11:09 AM
#4
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
Curious to see how this pans out. I did a quick look at this week's releases and, surprisingly, most have requirements below 4.3 (of course, there were a few that still had newer hardware requirements but the majority of them did not).

I don't know if these games were developed and submitted before the latest SDK came out. Or if they did a "workaround" as Blackharon suggested.

If they were submitted before the new SDK, but all newly developed games require the new SDK then, yes, it could spell the end of days for older devices. Obviously graphic intensive games that use the Unreal engine or just clearly too memory hogging for older devices, I understand the hardware limitations.

But if Apple forces apps, regardless of how complex they are, to only be published under the new SDK and 4.3, that's sad news. Yes, technology moves on, but if there's no real reason for requiring 4.3 then that's kind of saying that Apple wants to force people to upgrade.

They already have sort of dropped support by no longer giving iOS upgrades to older devices. But I don't think it's right to force devs to give up sales by leaving those who can't afford to upgrade in the dust.
11-03-2011, 11:24 AM
#5
I talked further - there's a tonne of confusion on the subject. According to my team you can still target any iOS version (fairly easily) however the simulator will only test with iOS 5 or iOS 4.3

Looking for a writer? PM me

Game Designer of:
Family Feud Matches Gaming with a side of Matchmaking!
Family Feud 2 My First Huge Apple Feature!
Pickpawcket
And more!
11-03-2011, 11:35 AM
#6
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
Quote:
Originally Posted by Blackharon View Post
I talked further - there's a tonne of confusion on the subject. According to my team you can still target any iOS version (fairly easily) however the simulator will only test with iOS 5 or iOS 4.3
Thanks. A dev also mentioned in another thread that Apple doesn't require the use of the new SDK. It's only if developers want to use all the new features like the iCloud, etc.

So maybe there still will be a bit of life left for us geezers with old hardware.
11-03-2011, 11:38 AM
#7
Joined: Dec 2009
Location: Berlin, Germany
Posts: 1,674
havent updated to the latest xcode &sdk yet but it would be weird if the lowest deployment target would be now 4.3 ... for eons it was 3.0 .. would be really weird if that changed..
11-03-2011, 12:19 PM
#8
Joined: Sep 2009
Posts: 2,240
Quote:
Originally Posted by awp69 View Post
Thanks. A dev also mentioned in another thread that Apple doesn't require the use of the new SDK. It's only if developers want to use all the new features like the iCloud, etc.

So maybe there still will be a bit of life left for us geezers with old hardware.
I was the one that mentioned that, so maybe I should clarify a few things, considering I haven't actually released an app, yet.

It does appear that Apple is trying to do away with older versions, but I don't see that they aren't allowing it. I'm running Xcode4 + SDK 5.0, and I set the deployment target to 4.0. In addition, I had to play with some architecture settings, as Apple doesn't add armv6 by default. But once those were set, we were able to get our program running on an older iPod running 4.2.1. So I can only assume that Apple will still allow that. I hope so, as we plan on supporting older devices! Xcode 4 allows for you to set the deployment target all the way down to 3.0.

Apple is definitely doing there part to make it more difficult to support older versions. You can still get Xcode 3 and SDK 4.3. However, Xcode 3 is incompatible with OS X Lion and SDK 5.0. So if you move to Lion, or wish to support iOS 5, then you are forced to move to Xcode 4 and SDK 5.0.

That shouldn't prevent anyone from building for older hardware, the shift is headed in that direction. I'm definitely no pro at this stuff, but those are my current observations.