★ TouchArcade needs your help. Click here to support us on Patreon.

Cavorite --> FREE

12-03-2011, 12:03 AM
#1
Senior Member [Original Poster]
Joined: Jan 2011
Posts: 320
Cavorite --> FREE


12-03-2011, 12:06 AM
#2
This is a neat game, so grab it will it's free.

The above post currently shows a price, but when you click through to iTunes, it's listed as FREE.

řƹȡ1

12-03-2011, 12:10 AM
#3
Joined: Jul 2009
Location: Houston/Austin, TX
Posts: 13,251
The only good game from the Appvent so far in my opinion. Make sure you pick this one up.

Twitter: @back2this
12-03-2011, 01:04 AM
#4
Joined: Jun 2011
Location: Here
Posts: 1,399
Looks awesome! Had been on my wish list, but I'll download to my computer. Kinda disappointed that this is 4.3 and up (I'm a 4th gen on 4.2.1). Any way I can get this on my device w/o jb or updating to 5.01 (assuming that a good lot of my games likely won't work AND it'll take a boatload of time)? Because I was seriously looking forward to this...

I don't want a signature.
12-03-2011, 03:50 AM
#5
Joined: Dec 2010
Posts: 147
It's a very nice puzzle platformer, go get it.
12-03-2011, 03:16 PM
#6
Joined: Aug 2011
Posts: 1,116
Darn it, the requirements are at least 2nd gen, but it also requires iOS 4.3. :C
12-03-2011, 03:36 PM
#7
Joined: May 2011
Location: Finland
Posts: 8,366
I don't get why people don't just update to another iOS... It's pretty simple...

Gameloft Live: IDontKiIIPpl (idontkiippl without capital letters)

I make EDM music No I'm not some pro who's signed to some major lable.http://YouTube.com/okayyymc3
12-03-2011, 03:42 PM
#8
Joined: Aug 2011
Posts: 1,116
Quote:
Originally Posted by LOLavi View Post
I don't get why people don't just update to another iOS... It's pretty simple...
2nd gen isn't compatible with 4.3, lol.
12-03-2011, 03:43 PM
#9
Joined: Jun 2011
Location: Here
Posts: 1,399
Quote:
Originally Posted by LOLavi View Post
I don't get why people don't just update to another iOS... It's pretty simple...
For me I never updated when 4.3.3 was the highest b/c it felt like a waste of time (there was no reason to update at the time). Now with 5.01 out, I don't update because a decent amount of games I like (including some that have since been pulled) likely won't work on the new OS....
Also FYI I'm a 4th gen...

I don't want a signature.
12-04-2011, 01:45 AM
#10
Joined: Apr 2009
Location: Portland, OR, Cascadia
Posts: 332
Quote:
Originally Posted by nfong View Post
Darn it, the requirements are at least 2nd gen, but it also requires iOS 4.3. :C
This was a mistake on my part -- sorry about that! It will be updated to run on 4.2 with the 1.0.3 update that I submitted tonight.