★ TouchArcade needs your help. Click here to support us on Patreon.

I am getting reports of crashes on iOS devices 4.3.3 and below, can anyone help?

12-03-2011, 07:36 PM
#1
Joined: Jul 2011
Posts: 169
I am getting reports of crashes on iOS devices 4.3.3 and below, can anyone help?

I'm the developer of Explodables, and I'm experiencing reports of crashing for iOS 4.3.3 and below.

Is there anyone who frequents these forums who has one of these devices that would be willing to test and send a crash report back to me so that I can try and figure out what is going on?

I can send promo codes out in exchange for help.

Many thanks in advance.
12-04-2011, 12:23 AM
#2
Joined: Oct 2011
Location: Missouri, USA
Posts: 6
I've got an iPhone 3G running 4.2.1 around. I can either test the retail version for you, or if you'd like, I can send you my UDID and you send me an Ad-Hoc version.
12-04-2011, 04:13 AM
#3
Joined: Sep 2010
Location: Morestel, France
Posts: 572
Quote:
Originally Posted by frankthechicken View Post
... so that I can try and figure out what is going on?
I can't help for the device but your problem is probably because you are using some framework not available on the older OS. You need to weak link these framework and handle the case when they are not present. Hope this help.

JC
12-04-2011, 04:34 AM
#4
Joined: Jul 2011
Posts: 169
Ovogame, you are right, it appears that somehow a stray linked library appeared (GLKit) it must have been a late night coding session which allowed that in.

In other words, I'm an idiot.

Last edited by frankthechicken; 12-04-2011 at 04:36 AM.
12-04-2011, 08:30 AM
#5
Joined: Aug 2011
Posts: 127
With mistakes we learn.

You are not idiot.
12-05-2011, 02:24 AM
#6
Joined: Sep 2010
Location: Morestel, France
Posts: 572
Quote:
Originally Posted by DomAjean View Post
You are not idiot.
Defintely
It's not like it only happen to you...