★ TouchArcade needs your help. Click here to support us on Patreon.

iPhone 3.0 Beta worth it?

05-07-2009, 10:48 PM
#1
Joined: Oct 2008
Location: Vancouver, BC
Posts: 1,652
iPhone 3.0 Beta worth it?

Would it be worth it to put the current 3.0 beta on my main iPod Touch? Are there any big problems with Beta 5 at the moment? Any major games that don't work with it? I know Unity games now work.

 /l、
(゚、
 l、 ~ヽ
 じしf_, )ノ Inconspicuous Group Cat?
05-07-2009, 11:53 PM
#2
Joined: Dec 2008
Location: Sacramento, CA
Posts: 4,568
Quote:
Originally Posted by Mew2468 View Post
Would it be worth it to put the current 3.0 beta on my main iPod Touch? Are there any big problems with Beta 5 at the moment? Any major games that don't work with it? I know Unity games now work.
I use it on my phone and have no problem with everyday use. build 3 was O.K. but build 4 was excellent, and build 5 is no worse.

I can't open dungeon defense, or Glyder....don't know why. But all unity games work.

I don't see why you shouldn't go to beta 3.0 if you have to option.

Plus it's required for all devs to now make sure their games are compatible with it, and any new submission have to be 3.0 to be accepted once 3.0 goes live. So you might as well.

Twitter: @Zincous

05-08-2009, 12:36 AM
#3
Joined: Dec 2008
Posts: 209
I'm sort of torn on whether I should install it on my iPod touch as well (been developing on a budget this far).

The problem is it says SDK 3.0 can't be used to submit 2.2.1 to the app store. Does this mean when you're exporting to 3.0, or is it completely impossible?

Maybe it's better to just look for beta testers with 3.0 beta 5 right now :/

any updates on the games I'm working on : www.twitter.com/jormy
05-08-2009, 02:29 AM
#4
Joined: Dec 2008
Location: Sacramento, CA
Posts: 4,568
Yeah I'm not exactly clear on the whole 3.0 testing/2.X submissions either
Hopefully some devs here can clear that up.

As for 3.0 beta 5 testers, I'm sure that wouldn't be too hard.

A couple of people posted in a lounge thread who have it, and I'm sure asking for 3.0 beta testers only wouldn't be too hard. If your interested in that route.

Twitter: @Zincous

Last edited by Zincous; 05-08-2009 at 02:32 AM.
05-08-2009, 04:46 AM
#5
Joined: Jul 2008
Location: Orlando, FL
Posts: 4,491
Quote:
Originally Posted by Zincous View Post
Plus it's required for all devs to now make sure their games are compatible with it, and any new submission have to be 3.0 to be accepted once 3.0 goes live. So you might as well.
Apps don't HAVE to be 3.0 compliant when it goes live.

You can keep your app as is and it will stay on the Appstore, but when 3.0 goes live any app that can not run on it will be removed from the appstore until it is updated.

It wouldn't be a bad idea to put together a very small bug fix update on 2.2.1, send it in for review on 3.0 and see if it's approved. If so then it will be fine, once 3.0 hits you can go back to your normal beta testers that have updated their firmware.

How many dev units can be registered to one account anyways? I'm sure there are other beta testers like me that would be happy to use the beta builds of 3.0 in order to help test
05-08-2009, 07:20 AM
#6
As of yesterday if your (new) App doesn't work on the iPhone 3.0 (build 5) OS, they will reject it. So it's a good idea to go ahead and put the 3.0 OS on your phone, build it in 2.2.1 and make sure it loads and runs correctly before you submit your app to Apple.
05-08-2009, 07:45 AM
#7
Joined: Apr 2009
Location: Munich
Posts: 384
Send a message via Skype™ to rdklein
yes I got also an email from Apple, from now all programs submitted will be tested against 3.0 B5 and need to run with it.

RadioactivityCounter on App Store developer of this App RadioactivityCounter 2012
Ports of Call on App Store developer of this game 1986-2009,
05-08-2009, 02:35 PM
#8
Joined: May 2009
Location: La Coruña, Spain
Posts: 191
Yes,

You can install both SDKs, so no pain for pre OS 3.0 builds.
05-09-2009, 12:30 AM
#9
Joined: Mar 2009
Posts: 324
Quote:
Originally Posted by rdklein View Post
yes I got also an email from Apple, from now all programs submitted will be tested against 3.0 B5 and need to run with it.
yay! this is good news for me. i think i have around 4 or 5 games that are not working with 3.0.
05-09-2009, 12:28 PM
#10
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by coolman View Post
Yes,

You can install both SDKs, so no pain for pre OS 3.0 builds.
How do you install both? I have both downloaded, is ther a way to switch between the two??