★ TouchArcade needs your help. Click here to support us on Patreon.

iPhone: Why can't i install Lucky Coins on a 1st gen iPod Touch?

05-10-2009, 01:42 AM
#1
Joined: Apr 2009
Location: CA
Posts: 336
Why can't i install Lucky Coins on a 1st gen iPod Touch?

Out of dozens of Apps that i have installed on one of my iPod Touch, Lucky Coins would not install, i get a message after syncing saying that "The application Lucky Coins was not installed since it's not compatible with your iPod Touch"
This is weird since i have the latest firmware (2.2.1) and the game is also installed and plays fine on my other 2 iPods, they're 2nd gen thought.
Please help.

1st & 2nd gen iPod Touch 3.0
XBL, Plus+ and OpenFeint: TheKrazyRussian
Fav Dev/Game: Self Aware Games / Sentinel 2.
Beta tested for Ngmoco, EA and Insomniac Games.
05-10-2009, 01:44 AM
#2
Joined: Apr 2009
Location: Where ever the good lord wants me to be.
Posts: 509
sometimes that pops up for me i think its cuz you need a 2nd gen ipod touch

OpenFient: Itzoliverstfu // Plus+: Pinoykid
05-10-2009, 01:54 AM
#3
Joined: Apr 2009
Location: CA
Posts: 336
Fixed it.
All i had to do is delete and download/install the App again.

1st & 2nd gen iPod Touch 3.0
XBL, Plus+ and OpenFeint: TheKrazyRussian
Fav Dev/Game: Self Aware Games / Sentinel 2.
Beta tested for Ngmoco, EA and Insomniac Games.