★ TouchArcade needs your help. Click here to support us on Patreon.

The TribeZ (game play discussion)

05-10-2012, 07:41 AM
Joined: May 2012
Location: Little old London
Posts: 3
Hello everyone. I am new here but have been playing The Tribez pretty much since the day it came out. Have been following the thread for a while now but thought I would finally comment as I am about 1000xp away form level 35. Keep up the good work guys!!
05-10-2012, 07:43 AM
Joined: May 2012
Location: Little old London
Posts: 3
Originally Posted by Triona View Post
Hi Everyone

I've been playing TT for a week or so now and am hooked! Still on the first island, but I am taking my time, I like to "smell the roses". Have been reading this forum and finally decided to join in the conversation, as everyone here seems to be very nice.

Silly question maybe but something that has bothered me from the start... Is there any way to get rid of the quest icon side bar (on the left side of screen) and the bottom icons? I find that they are often in the way as I cannot reach my little people to grant their wishes when behind them nor can I clear the land to build...


Hello, as far as I can gather there is no way to move the quest bar icon. I just filled that side of the screen with warehouses as I have no need to look at them etc.. Worst comes to worst you can just zoom in and then you can see pretty much all of the island! Hope this helps

05-10-2012, 07:47 AM
Joined: May 2012
Location: Little old London
Posts: 3
Originally Posted by Nessie View Post
Haha, thanx Kittycat. Been messing with the little people all morning since reading that.

Level 38 and getting bored as no more quests but can I ask if anyone knows how to get land behind statue on island 3 and I've got a mansion on the same island that was there when I arrived but keeps saying 'don't know what to do with this yet' any ideas?
Hello. Congrats on reaching level 38, I am almost level 35 and it's good to hear that there are more levels beyond 35. The mansion you are talking about belongs to one of the chiefs who visited previously and as such we can not move it. Apart form the fact that it's a mansion and not a multicoloured hut it's the same as the little huts with fences around them on the previous 2 islands.

With regards to the land behind the statue, I had the same question and after cutting down a single tree from within the sphinx area I thought it was possible but I have tried and tried but I have now given up. Sadly I think it's impossible..
05-10-2012, 06:24 PM
Level 34

Hello I'm new ;o)

I'm on level 34 and it's gonna take a long while to get to 35 .. Island 3 is nealy complete the sphinx should be finished by tomorrow but I am struggling to get all the capsules out of the UFO ;o(
05-10-2012, 08:56 PM
Joined: May 2009
Posts: 9
Capsules in UFO

I had that problem too, but ended up buying them for ... I think it was five crystals for all five at once. Saved me heaps of time and resources! The professor pops up and says thanks and that's all.

I think after this, you'll have the last quest to do, which is 15 long term stints in five markets. After that there are no more quests. You just have to collect money.
05-11-2012, 09:43 AM
Joined: May 2012
Posts: 5
4th Island

Does anyone know how to get to the fourth island yet? The Ancestor's Atoll I think it's called?
05-11-2012, 11:55 AM
I have 3 villas and 4 mutaplasm containers to get then I think I have finished the third ... I have not seen the 15 market deals quest yet ... But that won't take long I have 5 markets ;o)

The last update said there were 50 more quests .. I'm not sure where they are. Waiting for Island 4 to open up!
05-12-2012, 10:55 AM
Joined: May 2012
Posts: 7

Been playing for a while, am at level 31 but only on the 2nd island. I seem to have a tough time keeping the happiness level where it needs to be to move ahead very quickly. Am i doing something wrong? Maybe because I'm not spending real money?

Question: have you completed an island when there are no more quests there? doesn't seem much left for me to do on island 1. I keep exploring the plane and collecting rent. Should I be doing something else there?

Another thing, I often find I have done something, like build a couple of saunas then a goal will come up saying to build 3, but doesn't count the ones I have built.

Observation: if I were the inhabitants of the 1st island, I would not be happy with what has happened to it, was a nice little paradise and now is so crowded with buildings you can hardly walk around!

05-12-2012, 10:24 PM
Joined: May 2009
Posts: 9
Sounds like you have discovered the bugs that we are all grinding our teeth over....
-Once the quests are done on an island, there's nothing to do but collect money.
- if the quests tells you to build three more bath houses, you have to build three more bath houses, no matter how many you already have.

Your tribes happiness level is something you'll have to chase, by spending your coins ( not real money) on, and buy the islanders some pretty things. The best way to do this is to chose something that gives the most happiness points and takes up the least amount of space. I found the stone column to be the best. You'll have to stick them away on the sides of the island's playing area, or behind large buildings. Turn on the 'show grid layout' button (bottom of screen - with a house icon on it), to best see where to best place 'happiness items' that wont take up valuable screen realestate. Once placed you'll get the smiley face icon that will add itself to your happiness level.

Best of luck!
05-12-2012, 10:52 PM
Ancestor's Atoll

Hi, i'm now in level 37 but now stuck. Im just collecting profits and moving buildings here and there to get the achievements.

Anyone knows how to proceed and unlock Ancestor's Atoll? There's a quest in Marble Fiord to "purchase territory" but not working.