★ TouchArcade needs your help. Click here to support us on Patreon.

Which devices to support?

07-20-2012, 03:50 PM
#1
Joined: Aug 2009
Location: The Hague, The Netherlands
Posts: 68
Send a message via Skype™ to DylanNagel
Which devices to support?

Hi everyone,

I'm Dylan, and I'm about to submit my game to Apple. At first I planned for it to be an iPad exclusive, but since I am using Unity, there's really no excuse not to support iPhone and iPod touch too.

Which generations of these devices should I support though? I guess this question is also tied to the iOS version.

Any hints would be greatly appreciated, thanks!
07-20-2012, 04:05 PM
#2
iPhone 3GS+, iPod Touch 3rd gen+ and all iPad owners; iOS 4.3 and above.

Straight from All in's Game Design Document.

Though it really depends on your app. Is it CPU/Memory intensive? Up it a generation or 2. Is it super-casual? Consider 2nd gens too!

If you're concerned about target audience a quick google search shows a few somewhat-recent statistics here and here

Looking for a writer? PM me

Game Designer of:
Family Feud Matches Gaming with a side of Matchmaking!
Family Feud 2 My First Huge Apple Feature!
Pickpawcket
And more!
07-20-2012, 04:57 PM
#3
Joined: Aug 2009
Location: The Hague, The Netherlands
Posts: 68
Send a message via Skype™ to DylanNagel
Thanks a lot for your reply, Blackharon!

I was surprised to see the adoption rate of iOS 5+, since certain older devices are limited to 4.3 something. However, there's a fairly high percentage left of such users on iPod touch especially, it seems.

My game runs well on iPad 2 and iPhone 4S, but still needs a bit of optimization for iPad 1. Hopefully if I get it to perform well on that device, it will also run well on iPhone 3GS and iPod touch 3.

The only thing I'm a little concerned about is the actual pixel resolution on those older devices: there's not a lot of screen real estate to go around. Ah well, I started making games during the glorydays of MCGA, which was 320x200 pixels, 256 colors!

But yeah, it would be cool to be able to reach those with aging iPods, I am sure they still want to play games too!

Thanks again.
07-22-2012, 05:55 AM
#4
Joined: Feb 2011
Location: Isle of Wight, UK
Posts: 1,509
Yeah, the iPods are always the hold up. People tend to have reasonably modern phones (current or previous gen) as most of us get "free" upgrades on contract.

But there's really no need to keep an iPod current. A new one will still play the same songs just as well as the older ones. Although, people intending to play games probably will upgrade occasionally so maybe you're trying to be inclusive to people who aren't in your market.

We support anything 3GS or newer (for the shader support) and let the market sort itself out!
07-23-2012, 02:21 AM
#5
Joined: Aug 2009
Location: The Hague, The Netherlands
Posts: 68
Send a message via Skype™ to DylanNagel
Thanks for your answer, Rubicon, good to know!