★ TouchArcade needs your help. Click here to support us on Patreon.

How to enable 3.0 compatibility in apps

06-11-2009, 06:21 AM
#1
Joined: Mar 2009
Location: Singapore
Posts: 1,770
Send a message via AIM to kohjingyu
How to enable 3.0 compatibility in apps

Hey guys, I was wondering how do you make your apps compatible with 3.0? Do you add some code or what? And what does new APIs mean? Is there any change in the programming language?
06-11-2009, 02:21 PM
#2
Joined: Feb 2009
Posts: 132
You install SDK 3.0 and check if it works.
06-12-2009, 12:51 AM
#3
Joined: Mar 2009
Location: Singapore
Posts: 1,770
Send a message via AIM to kohjingyu
Quote:
Originally Posted by jaguard View Post
You install SDK 3.0 and check if it works.
If it doesn't work how do I make it work?
06-12-2009, 01:13 AM
#4
Joined: Apr 2009
Location: Munich
Posts: 384
Send a message via Skype™ to rdklein
check in debug modus where it crashes.
I haad this twice with my apps,
one was a problem in the multithreading and the latest problem
I had was with tables, where during the edit mode a program crashes when refreshng the table data whichworked in 2.2.1 so I had to change the code till it works.

RadioactivityCounter on App Store developer of this App RadioactivityCounter 2012
Ports of Call on App Store developer of this game 1986-2009,