★ TouchArcade needs your help. Click here to support us on Patreon.

Games that require 3.0 to install

06-17-2009, 11:32 PM
#1
Joined: Mar 2009
Location: Seattle, WA USA
Posts: 4,761
Games that require 3.0 to install

After updating, Enigmo and Alternate Endings now require the 3.0 update to install. Are there any others?

Last edited by DaveMc99; 06-18-2009 at 12:17 AM.
06-17-2009, 11:40 PM
#2
Joined: Mar 2009
Posts: 6,272
Arn wrote this on the home page...

Hopefully, you've been able to get the new 3.0 firmware installed and activated on your iPhones or iPod Touches. If you are looking for do something with the new functionality, here are a few new 3.0-updates that were announced today. Besides push notification support, peer-to-peer play, and iPod music support, we're already seeing in-app purchasing add ons.

The actual updates are free for those who own the apps, but a couple introduce in-app purchasing which may require additional money to gain new content.

Vans SK8: Pool Service ($2.99) - allows you to select music from your iPod playlists.
Leaf Trombone ($0.99) - New Duet mode with peer-to-peer Bluetooth and "Achievement Alerts" using 3.0's push notification service.
Enigmo ($2.99) - New in-app purchasing level packs. There are currently two new Level Packs available: Kidís Pack #1 and Kidís Pack #2. The new levels in each of these Level Packs have been designed specifically for kids.
Flick Fishing ($0.99) - Peer to peer networking support with new game mode (Fish Jack), and inclusion of a new In-App Purchase: "Private Beach Pack" which includes new fishing location, 4 new fish.
Topple 2 ($2.99) - playback music from your iPod playlists within Topple 2.
Star Defense ($5.99) - A new planet in Challenge Mode, Plus+ network integration (online leaderboards and more) and 3.0 Push Notification support: direct challenges sent to your friends.

06-18-2009, 11:01 AM
#3
Joined: Mar 2009
Location: Seattle, WA USA
Posts: 4,761
Quote:
Originally Posted by freedog View Post
Arn wrote this on the home page...
Arn also wrote this which apparently is not true with all games: "All these games will continue to support the older firmwares, of course, but the new 3.0-specific features will not be available to those users."

Is anyone else finding games that require 3.0 that will not install on 2.2.1?
06-18-2009, 11:13 AM
#4
Joined: Mar 2009
Location: USA
Posts: 1,944
Baseball Sluggers: Homerun Race 3D
06-18-2009, 12:43 PM
#5
I only noticed Enigmo.

Good news though: you don't lose the old version. You download the update to your computer, and then when you sync you get a warning from iTunes (which you can "never show again" if you wish) that the app can't be installed because you need a newer OS. But the old version of the app STILL remains on the device. (And I'm sure the new one syncs later when you upgrade the OS.)

BUT... I don't know what happens if you wipe and restore your iPhone running the old OS. AFAIK, entire apps aren't included in the backup, just the data (game progress) you've stored in them. And if that's true, then I don't see how the old version could be restored (it's in your trash--I checked). You might lose all your data in that app because the backup for it has noplace to restore to: the new app won't install, and the old app is gone. This is just my guesswork, though. (And a moot point for me since I'm installing 3.0 soon anyway.)

Morgan Adams (GameCenter: ďAdams ImmersiveĒ)
My upcoming first game: Scree (Forum thread)
My upcoming VR horror experience: This is Not the Church of the Worm (Forum thread)
Stop making lists. Organize with shapes and colors instead: DotSpace (Forum thread)
06-18-2009, 02:24 PM
#6
Joined: Mar 2009
Location: Seattle, WA USA
Posts: 4,761
Quote:
Originally Posted by Adams Immersive View Post
I only noticed Enigmo.
I think it is a developer problem.. some must be thinking if they have 3.0 features then it is required to have 3.0
06-18-2009, 02:43 PM
#7
Joined: Mar 2009
Posts: 6,272
Quote:
Originally Posted by DaveMc99 View Post
Arn also wrote this which apparently is not true with all games: "All these games will continue to support the older firmwares, of course, but the new 3.0-specific features will not be available to those users."

Is anyone else finding games that require 3.0 that will not install on 2.2.1?
yes I just bought Adrenaline Pool Online 2 and it would not tlet me install until I DL the new 3.0 update.
06-20-2009, 10:13 AM
#8
Joined: Apr 2009
Location: Toronto, Ontario
Posts: 63
Flick Fishing apparently requires 3.0 to install now.