★ TouchArcade needs your help. Click here to support us on Patreon.

Build at the AppStore is different that what I uploaded

11-01-2012, 01:42 PM
Joined: May 2011
Location: India
Posts: 26
Build at the AppStore is different that what I uploaded

The current version has new audio, new icons. Take a look at the top right in the screenshots and the videos:

Zombie version:



Youtube link | Pop Up

Expected version.



Youtube link | Pop Up

But every time I download my own app from the app store {itunes link} I get the older version. And when I run from the Xcode the newer version runs, and I haven't touched the code since submitting to AppStore.

I searched on google, devforums.apple and no one seems to have faced something like this.

I've even tried downloading using a Promo code. I think the device sort of caches the app, even after I delete it. Because with every install I even get the GameCenter notifications even though I commented out all the GameCenter code in the final release.

This is the first submission, not an update.

What could be the explanation? Is this some sort of Apple's Halloween prank? What is the protocol for downloading your own app on your testing devices?

The issue is not resolved. Thanks everyone for their help.

Last edited by chunkyguy; 11-05-2012 at 05:59 AM. Reason: Issue Resolved
11-03-2012, 07:35 AM
Have you tried deleting the app from the device and then doing a full clean and rebuild?

It sounds like it's possibly just an asset timestamp issue. So perhaps you replaced some pngs with some that are actually older (according to their timestamp), so these aren't getting transferred to your device when you run it, yet the archive built for the App Store is using the later (but 'older') pngs.

A total guess though, as I'm not quite sure I understand the problem.

Apps: Lead Wars (TA Thread) | Super Grav (TA Thread) | 3D Spinner (TA Thread)
DemonStudios Ltd | Indie Game Dev
Follow: Facebook | Twitter
11-03-2012, 09:28 AM
Joined: Mar 2009
Location: Singapore
Posts: 1,770
Send a message via AIM to kohjingyu
I agree, I think a full re-install/clean would solve the problem. Can't think of anything else unless you uploaded the wrong build..

Did you try the app on a separate device?
11-05-2012, 05:56 AM
Joined: May 2011
Location: India
Posts: 26
The issue is resolved. Thanks guys for your help.

The issue was due to my uploading the wrong binary. I've now submitted the correct build, it's in the Apple's review system.

The stupidest mistake a person can make for his first app.