★ TouchArcade needs your help. Click here to support us on Patreon.

OS 3.0: Stop Complaining, Keep Up

06-29-2009, 12:21 PM
#1
Joined: Dec 2008
Location: Seattle, Wa
Posts: 278
OS 3.0: Stop Complaining, Keep Up

I've been hearing quite a few people complaining about games going 3.0 compatible only and I don't understand the issue. I know you've got your device right where you want it or you've jailbroken and your apps, stolen or not, would not function properly on 3.0. the fact remains, like any computer with an OS (Windows, Leopard, Linux, etc.) developers have to move, and yes, update their titles, and the users have to follow. As being a developer, I understand having to upgrade can be a pain with the changing time. Heck, eventually, Apple will no longer support your 1 & 2G devices. You'll have to get the newer, faster hardware to play the new titles and developers are pulling their old stuff to follow that trend.

I think it's time you understand that this isn't an upgradable hardware platform like a desktop computer, but considering what you get out of it, your not spending a whole lot of money to keep up. Apple is dropping prices on it's devices and developers are dropping their prices on software to keep up and compete.

Please, no more complaints. Discuss if you differ.

Last edited by Zandog; 06-29-2009 at 12:47 PM.
06-29-2009, 12:23 PM
#2
Joined: Sep 2008
Location: Earth
Posts: 5,252
Quote:
I know you've got your device right where you want it or you've jailbroken and your apps, stolen or not, would not function properly on 3.0. the fact remains,
That's not exactly the problem. 3.0 is already jailbroken and I'm pretty sure you can once again use cracked apps. The only problem is that 3.0 is sorta buggy, a lot of people are waiting for 3.0.1. But I agree, I wish people would not complain so much.

I'M ON A MAC MOTHAF*@%!

Cloudcell, Plus+, Baseball Slugger, TTR: dannys95

06-29-2009, 12:26 PM
#3
Joined: Mar 2009
Location: Seattle, WA USA
Posts: 4,761
Quote:
Originally Posted by Zandog View Post
Please, no more complaints. Discuss if you differ.
The problem is now there are more apps that do not work under 3.0 than there are apps that require 3.0. That will change as Apple approves the update fixes. Til then it is a bit of a hassle.
06-29-2009, 12:31 PM
#4
Joined: Dec 2008
Posts: 686
Quote:
Originally Posted by Zandog View Post
I think it's time you understand that this isn't an upgradable hardware platform like a desktop computer, but considering what you get out of it, your not spending a whole lot of money to keep up. .
Buying a new ipod touch/ iphone on each version is an expensive business.

As for OS3 - my wifi and internet are ****ed by it. Never been jailbroken, been treated with care. Paid-for Apple code came into an Apple computer, went along an Apple cable to an Apple ipod touch and it ***ed it. I'll bitch all I want about OS3


06-29-2009, 12:33 PM
#5
Joined: May 2009
Posts: 233
The iPod Touch upgrade from 2.2.1 to 3.0 is like the upgrade from Windows XP to Vista.

Just because it's newer doesn't mean I need it. With the new OS release, some stuff that worked under the old OS no longer works (properly).

If I was buying a new iPod Touch, I'd expect it to be on there, but otherwise, I wouldn't pay for the upgrade and I expect that all of my software that worked on my iPod last week/month/year should still continue to work. Apps are not sold on a subscription model, so I shouldn't need to pay anything to keep them working.
06-29-2009, 01:08 PM
#6
Joined: Dec 2008
Location: Seattle, Wa
Posts: 278
Quote:
Originally Posted by DonD_GT View Post
Apps are not sold on a subscription model, so I shouldn't need to pay anything to keep them working.
Your right, it should be the developers obligation to keep their apps compatible and Apple enforces that by pulling the app if it does not meet the working guidelines of 3.0

--------------------------------------------------------------
Touch Arcade Developer's Group Coordinator
Follow me on Twitter

Guidelines To Offering & Receiving Services
06-29-2009, 01:30 PM
#7
Joined: Feb 2009
Posts: 2,476
Quote:
Originally Posted by Zandog View Post
Your right, it should be the developers obligation to keep their apps compatible and Apple enforces that by pulling the app if it does not meet the working guidelines of 3.0
But doesn't this screw the consumer?? Shouldn't apple, seeing as they make around 30% of each sale, be somewhat responsible for making sure my product purchased through they're store works properly? Pulling the app doesn't get the app working again. Not being a dick, I'm sincerely looking to you for insight.

My friend said to me, "I think the weather's trippy." I said, "No, man, it's not the weather that's trippy, perhaps it is the way that we perceive it that is indeed trippy." Then I thought, "Man, I should've just said, 'Yeah."CS.one R3DC3ll Faction-Join us or die...proud member of TheBeastlyNinja Epic-uber elite comedy crew
06-29-2009, 01:36 PM
#8
Joined: Mar 2009
Posts: 1,657
Quote:
Originally Posted by le'deuche123 View Post
But doesn't this screw the consumer?? Shouldn't apple, seeing as they make around 30% of each sale, be somewhat responsible for making sure my product purchased through they're store works properly? Pulling the app doesn't get the app working again. Not being a dick, I'm sincerely looking to you for insight.
Apple screws us but they been doing that for years. Apple shouldn't make it compatible for everyone because it's the dev who has too and this is because with 3.0 dev have more flexibility and they will use it and the older version can't without the upgrade so it's your choice not us.

Quote:
Originally Posted by Somerandomdude View Post
...I vink you fail good sir. I don't vink vat yo get ze jok.
Proud Member of SAB
SAB Intelligence Officer
06-29-2009, 01:38 PM
#9
Joined: Feb 2009
Posts: 2,476
But what if the developer is no longer around? Then I get the shaft?? I mean apple still has GI joyride on the app store, and that's been abandoned.

My friend said to me, "I think the weather's trippy." I said, "No, man, it's not the weather that's trippy, perhaps it is the way that we perceive it that is indeed trippy." Then I thought, "Man, I should've just said, 'Yeah."CS.one R3DC3ll Faction-Join us or die...proud member of TheBeastlyNinja Epic-uber elite comedy crew
06-29-2009, 01:52 PM
#10
Joined: Feb 1983
Location: Barcelona
Posts: 1,268,691
Quote:
Originally Posted by le'deuche123 View Post
But what if the developer is no longer around? Then I get the shaft?? I mean apple still has GI joyride on the app store, and that's been abandoned.
GI Joyride works great on both 3.0 and the 3GS.