★ TouchArcade needs your help. Click here to support us on Patreon.

Just had an App smash my OS. Anyone else?

07-23-2009, 11:57 PM
#1
Joined: May 2009
Posts: 545
Just had an App smash my OS. Anyone else?

iPhone 3g only 8 months old and suddenly yesterday the battery started draining at an alarming rate. Couldn't hold a charge and was always warm even when the screen was off.

I work for a battery company and I know batteries don't go that bad that quick. According to the diagnosis software at the apple store it was a recently installed app that crossed some wires within OS3. Been happening a lot according to them, even one's that have been approved.

Solution: Wipe the phone and re-install everything except the recent apps. 3 Hours later it looks like it's better. Anyone else see this recently?

07-24-2009, 12:28 AM
#2
Joined: Mar 2009
Location: London, UK
Posts: 2,280
Quote:
Originally Posted by deadweight View Post
iPhone 3g only 8 months old and suddenly yesterday the battery started draining at an alarming rate. Couldn't hold a charge and was always warm even when the screen was off.

I work for a battery company and I know batteries don't go that bad that quick. According to the diagnosis software at the apple store it was a recently installed app that crossed some wires within OS3. Been happening a lot according to them, even one's that have been approved.

Solution: Wipe the phone and re-install everything except the recent apps. 3 Hours later it looks like it's better. Anyone else see this recently?

i actually had that same issue not to long ago on my 3g. What game was it that caused this for you?

You are not pretty enough to be that stupid.
07-24-2009, 07:08 AM
#3
Joined: May 2009
Posts: 545
Quote:
Originally Posted by iphoneprogrammer View Post
i actually had that same issue not to long ago on my 3g. What game was it that caused this for you?
I've got it nailed down to 1 of 2 games I installed recently, but wouldn't be fair to the devs to say which. Could have just been a blip during install... who knows.

Just thought it was interesting to see an app screw with the OS... even when the app wasn't running.
07-24-2009, 07:42 AM
#4
Joined: Jul 2008
Location: Boston
Posts: 1,268
Quote:
Originally Posted by deadweight View Post
it was a recently installed app that crossed some wires within OS3.

Solution: Wipe the phone and re-install everything except the recent apps. 3 Hours later it looks like it's better. Anyone else see this recently?

so this is just on the iphone 3gs?

i have an ipod touch, 1st gen, and in the first month, experienced that any case, with magnets, would physically move something, and hard force the device off, even though the case companies - denied it, over at macrumors, we found that thousands of people could prove it..

so with the 3gs, is it a hardware issue, how can software cross wires?
07-24-2009, 08:44 AM
#5
Joined: May 2009
Posts: 545
Quote:
Originally Posted by mek View Post
so with the 3gs, is it a hardware issue, how can software cross wires?
It's actually a 3g. And it was just software related... "crossing wires" was a figure of speech. An app that could change the hardware? Now THAT would be woth $0.99.

I have had something nearly similar happen to one of my kid's iPod Touch 2ndGen however. The most obvious symptom was that it lost the name of the device and continuously asked to be activated on iTunes every few weeks. My problem was with Os3.0 but the iPod was still on 2.2. Odd.