★ TouchArcade needs your help. Click here to support us on Patreon.

Games Not Tested For 3.0

07-27-2009, 10:03 PM
#1
Senior Member [Original Poster]
Joined: May 2009
Location: Lala Land
Posts: 1,063
Games Not Tested For 3.0

What are the games that aren't tested for 3.0 yet besides need for speed(which runs perfectly for me on 3.0) and is there a list? And should it be a requirement for all games to be 3.0? I know it's required for new games but I'm talking about the older games

memory cards

Last edited by Ajg3; 07-27-2009 at 10:07 PM.
07-28-2009, 10:14 AM
#2
NFS won't run for me

NOW PLAYING:
Frenzic,Zenonia,Azkend,Stoneloops!,Montezuma,Drop7 ,
StarDefense,Trism,Peggle,MGSTouch,Zombieville and many more