Some apps have just never worked for me - help?

09-19-2013, 07:35 AM
#1
Some apps have just never worked for me - help?

Hey guys. I currently own an iPhone 5 with iOS 7, and my problem is that some apps just NEVER want to open, across software and hardware versions. I've also owned a 4 fairly recently, and this has been happening since 6.1. Probably earlier, too...some apps it's been happening since November of last year.

Anywho, apps such as Zombiewood, Asphalt 8, and Kingdom Rush haven't opened on either of my iPhones, on any iOS version, under any circumstances. They'll usually reach their respective loading / logo screens, and then just crash to home. I've also seen this problem with ANYTHING Gamevil has made, but switching over to Airplane Mode lets me play Cartoon Wars: Blade.

I have tried...turning off and on, reinstalling the apps, resetting settings, turning off via the lock AND home button, but to no avail. I have not tried doing a factory restore and then restoring my content, because A), it's a hassle, and B), problem persists on my new iPhone 5 - and that came in factory condition.

So, any ideas?
09-19-2013, 10:51 AM
#2
Joined: Dec 2010
Location: Houston, TX
Posts: 9,314
I have not heard of cross hardware crashes and huge titles like Asphalt 8 should be stable. I'd recommend making an appointment for the Genius Bar at your nearest Apple retailer. They can provide free trouble shooting and have software to analyze crash history and stability problems.