★ TouchArcade needs your help. Click here to support us on Patreon.

My MOGA ACE POWER Experience. What's yours?

11-30-2013, 04:01 PM
Joined: Nov 2013
Posts: 4
My MOGA ACE POWER Experience. What's yours?

So I recently picked up a MOGA Ace Power.
The company's email said it would come in the post on the 29th November, and they were bang on! No delay at all.
After unboxing it and plugging it into my iPod, which I had stripped of all non-controller games and filled with controller compatible ones, it worked! That's good. It looks a bit cheap but it is comfortable. You really get so much more of a feel to the games you're playing. And the headphone jack seems to boost the audio a bit!

Anyway, at about 20 minutes in, it stopped working. I tried poking the reset switch on the back with a toothpick and it worked again. 10 minutes later, it happened again. And again. And again.

In conclusion, I'll take it everywhere, I'll just bring a toothpick.

But seriously, what if you're mid game and this happens?
Speaking of that, Ravensword Shadowlands is completely mucked up.

Anyone else had to constantly reset?
12-02-2013, 08:28 AM
I wrote a huge post about it...

I wrote a huge post about it on my blog

All in all, the games that work well with it are greatly enhanced by playing with the Power Ace IMO. The hugely improved comfort is key too. I couldn't spend as long as I do playing Oceanhorn without the controller, that's for sure! And Dead Trigger 2? I didn't play it for an hour when it came out. For me, the controller made it worth playing... Until the free to play bull totally turned me off.

I've "only" had to reset mine twice in a week... Their site mentions having to do this after draining the battery but in my experience it seems pretty random. I wonder why we even have to reset the controller... What does that reset button even do!?

Last edited by psj3809; 01-23-2014 at 07:46 AM. Reason: Advertising own site
01-23-2014, 06:53 AM
Joined: Nov 2013
Posts: 4
I just got one of those Moga Aces and as expected it works pretty sweet with Oceanhorn. Really cool not to have my fingers taking up half the screen! I was as well really looking forward to play Ravensword:Shadowlands with it but it crashes the game every time I try to launch it: get strangely teleported outside of the map as soon as loading finishes and the controls don't work at all...
Any clue on how to fix that? I might drop the Moga mob a short hate mail...