★ TouchArcade needs your help. Click here to support us on Patreon.

IOS App rule Change per 2/1/2014

01-08-2014, 10:02 PM
#1
IOS App rule Change per 2/1/2014

The new rule goes into effect on February 1, 2014 and means that any apps built on older versions of Xcode or non-iOS 7 optimized apps will be rejected from the App Store.

In addition, this also applies to app updates, providing some inspiration for developers to update their developer tools and optimize their apps for iOS 7 as the updates will be rejected otherwise. Optimizing an app for iOS 7 does not necessarily mean it needs to look different, but that the underlying construction of the app must be optimized for the new OS.


http://www.macrumors.com/2013/12/17/...on-february-1/

Last edited by pka4916; 01-08-2014 at 10:07 PM.
01-08-2014, 10:05 PM
#2
I almost died inside, but realized us ios 6-era player will still get new games and updates. Whew

01-08-2014, 10:07 PM
#3
Quote:
Originally Posted by christopherrocs View Post
I almost died inside, but realized us ios 6-era player will still get new games and updates. Whew

They will, but they need to be compiled for IOS7 so people are forced to move on.
01-09-2014, 01:16 AM
#4
Joined: Jan 2012
Location: The rainbow-fuelled nightmare of my mind
Posts: 2,760

I'm just lurking here...menacingly!
01-09-2014, 02:53 AM
#5
Joined: Jan 2011
Location: England
Posts: 10,469
Hooray ! Hopefully that'll stop 17 tons of 'oh no its only ios7 compatible' posts

Love the way ios7 looks, was a bit slowish on my iphone 4 but all other devices higher are fine.
01-09-2014, 03:20 AM
#6
Quote:
Originally Posted by psj3809 View Post
Hooray ! Hopefully that'll stop 17 tons of 'oh no its only ios7 compatible' posts
.
Seems like there will be more posts, cause there will be more games ios 7 only.
01-09-2014, 05:55 AM
#7
Great. This is good news.

Last edited by HansKaosu; 01-09-2014 at 06:12 AM.
01-09-2014, 06:48 AM
#8
Quote:
Originally Posted by Connector View Post
Seems like there will be more posts, cause there will be more games ios 7 only.
I think he means everyone will have to update and therefore, stop saying it.

So glad I updated back when castle of illusion came out, otherwise I'd be so pissed right about now.

Currently addicted to: Duet game, Threes, Tengami, Oquonie, Platforms Unlimited, Perloo, Wave Wave
01-13-2014, 03:23 PM
#9
Also the Really old Gen. ipad/itouch/iphones are going to be out of luck...
Finally stop the bitching about "It doesn't work on my Ipad 1"
01-13-2014, 10:46 PM
#10
Joined: Jan 2013
Location: The Garden of Sinners
Posts: 1,841
Quote:
Originally Posted by psj3809 View Post
Hooray ! Hopefully that'll stop 17 tons of 'oh no its only ios7 compatible' posts

Love the way ios7 looks, was a bit slowish on my iphone 4 but all other devices higher are fine.
I don't care about the look, but 500MB RAM is still quite tight for iOS7. What's the point of being able to purchase new apps if half of them lag? Really, Apple and their hardware upgrade progress...

=>> HEY YOU! Why own an iPad if you haven't played CRABITRON? <<=

Playing: Corridor Z, Goblin Sword, Lost Toys, Duet Game, Layton Brother, Threes!, Solomon's Keep, Crabitron, Punch Quest, IB3, Sword & Sworcery (Recommend them all!)