★ TouchArcade needs your help. Click here to support us on Patreon.

Ipod touch 3.0 question

08-12-2009, 10:42 AM
#1
Joined: Jun 2009
Posts: 754
Ipod touch 3.0 question

i use a 1G ipod touch, so if i download the latest update for 3.0 version, which is said to be only for the 2G model, will i be able to play 3.0 games?
08-12-2009, 10:45 AM
#2
Joined: Jun 2009
Posts: 10,965
I can't speak for this directly, (as I have a 2nd gen iPod Touch) but have heard from others with a 1st gen here on TA that they upgraded to 3.0 to play certain games that require it.

No major complaints that I've heard of (other than the lack of value in upgrading and the cost...)

Quote:
Originally Posted by NickFalk View Post
Squids!?

Worst idea ever!

08-12-2009, 10:55 AM
#3
Joined: Jun 2009
Posts: 1,532
Yeah i have a 1g, and you will be able to play 3.0 games. its good, if you use your ipod enough to make it worth the ten dollars.
08-12-2009, 11:01 AM
#4
Joined: Dec 2008
Location: Cardiff, Wales, UK
Posts: 388
3.0 os is for all ipod touch versions.

i haven't yet upgraded my 1st gen because of too many known wi-fi issues, but as yet, the only game i've come across souly dedicated to 3.0 os i havent been able to download is topple2. althou there are more out there too.
08-12-2009, 11:22 AM
#5
Joined: Jun 2009
Location: California
Posts: 1,506
Quote:
Originally Posted by Aspargusman View Post
i use a 1G ipod touch, so if i download the latest update for 3.0 version, which is said to be only for the 2G model, will i be able to play 3.0 games?
yes, and soon enough all games will require 3.0
08-12-2009, 02:08 PM
#6
Joined: Jun 2009
Posts: 754
ok, then what?

i tried installing itunes 8 but nothing shows up. the screen just shows thank you for downloading itunes 8.
08-12-2009, 02:53 PM
#7
Joined: Jun 2009
Posts: 754
Quote:
Originally Posted by upsidedown View Post
Yeah i have a 1g, and you will be able to play 3.0 games. its good, if you use your ipod enough to make it worth the ten dollars.
but the upgrade page says only for 2G ipod touch
08-12-2009, 05:42 PM
#8
Joined: Feb 2009
Location: Singapore
Posts: 1,755
You are reading it wrong. That's a footnote referring to the new stereo bluetooth ability, it's not a condition.
08-12-2009, 06:05 PM
#9
Joined: May 2009
Posts: 1,418
Quote:
Originally Posted by Aspargusman View Post
i use a 1G ipod touch, so if i download the latest update for 3.0 version, which is said to be only for the 2G model, will i be able to play 3.0 games?
Yes. I have a touch 1g and it plays Star Defense and D. Chronicles fine.

Currently Playing: Ascension: Chronicle of the Godslayer, Summoner Wars

Game Center: Camzeee