★ TouchArcade needs your help. Click here to support us on Patreon.

Question about app upgrade... new os

09-01-2009, 11:29 AM
#1
Joined: Dec 2008
Posts: 439
Question about app upgrade... new os

Our new game does not currently use any 3.0 functionality. The minimum required os is 2.0.

But in the future we might put in bluetooth multiplayer... which would require the customer have os 3.0.

Is it possible to keep the minimum version as 2.0, and have bluetooth only available for the 3.0 players? Meaning... is there a way for the code to know... this iphone only has 3.0 installed, so run the required bluetooth code... this iphone doesn't have 3.0 so don't run the bluetooth code...

Thanks.
09-01-2009, 11:34 AM
#2
Joined: Jun 2009
Posts: 10,968
It must be possible as Flight Control plays over bluetooth, but the app store description says that it requires OS 2.0 and above.

Quote:
Originally Posted by NickFalk View Post
Squids!?

Worst idea ever!
09-01-2009, 11:56 AM
#3
Joined: Dec 2008
Posts: 439
Quote:
Originally Posted by drelbs View Post
It must be possible as Flight Control plays over bluetooth, but the app store description says that it requires OS 2.0 and above.
Thanks drelbs!
09-01-2009, 01:25 PM
#4
Joined: Jun 2009
Location: California
Posts: 1,506
that's how alot of games are
09-01-2009, 01:43 PM
#5
Joined: May 2009
Location: Durham, UK
Posts: 96
Send a message via MSN to daveak
1) Set the base sdk as 3.0
2) set the deployment target as 2.0
3) any 3.0 specific frameworks set to weak instead of required.
4) check for the existance of the classes / selectors you want to use in code before you use them.

Alpha Numeric - Find words and solve sums against the clock.