★ TouchArcade needs your help. Click here to support us on Patreon.

[Ad Mob - Developer Help]

05-09-2015, 01:34 PM
#1
Joined: Jan 2013
Posts: 45
[Ad Mob - Developer Help]

Hi,

I've just launch a new game and I used Ad Mob in it. Suddenly I found some of the devices have shown the Ad Mob and some are not. What's wrong in it? I also found Ad impression is quit slow. What should I do? Developer please help me. Thank You
05-09-2015, 05:55 PM
#2
Joined: Aug 2013
Posts: 1,065
Admob doesn't deliver to some countries. Also they might of turned data off on their phone which means the ads won't show.

Please follow me on twitter @JamesDestined I post lots of development from both my game creation and professional development.
Time to measure - Brain challenge https://itunes.apple.com/us/app/time...820864672?mt=8
The light box, can you solve it (free) (on google play too)
https://itunes.apple.com/us/app/the-...6300?ls=1&mt=8
05-11-2015, 01:25 PM
#3
Joined: Jan 2013
Posts: 45
Quote:
Originally Posted by Destined View Post
Admob doesn't deliver to some countries. Also they might of turned data off on their phone which means the ads won't show.
Thanks, but I have downloaded my previous game 'Bubbling Tapping' and my new game 'Headache' in a single device. I found 'Bubble Tapping' shows the ad on the other hand 'Headache' does not show any ad. Though 'Headache' shows ad in my another device.
05-11-2015, 03:23 PM
#4
Does it *never* show an ad or just sometimes not show an ad.
It could be a fill rate issue.

Looking for a writer? PM me

Game Designer of:
Family Feud Matches Gaming with a side of Matchmaking!
Family Feud 2 My First Huge Apple Feature!
Pickpawcket
And more!
05-11-2015, 04:08 PM
#5
Joined: Aug 2013
Posts: 1,065
You make it sound like a coding issue.

Please follow me on twitter @JamesDestined I post lots of development from both my game creation and professional development.
Time to measure - Brain challenge https://itunes.apple.com/us/app/time...820864672?mt=8
The light box, can you solve it (free) (on google play too)
https://itunes.apple.com/us/app/the-...6300?ls=1&mt=8
05-19-2015, 03:41 AM
#6
Joined: May 2015
Location: Wrocław, Poland
Posts: 5
Have you coded everything like in the Google's instruction pdf? If yes, everything is ok. There are many factors that may cause your problem (user country, your "rating", fill rate etc), so don't worry.

I "blogging" regularly on iOS Apps Weekly.