★ TouchArcade needs your help. Click here to support us on Patreon.

X-code 7 and Emulators

06-23-2015, 07:49 PM
#1
Joined: Sep 2013
Posts: 180
X-code 7 and Emulators

Apologies if there's already a thread about this that I've missed, or if this is the wrong forum. Or indeed if this is against the rules..

I've managed to install Gba4ios, provenance and MeSNEmu by compiling myself in XCode 7.

Just wondering if others have had success with any others, eg retroarch, mame etc
06-23-2015, 08:25 PM
#2
Joined: Jan 2011
Location: England
Posts: 10,656
How did you do this ? A dev license or beta ios 9 ? I read that people could potentially compile apps themselves in ios9

Is that what you've done here ? Was it easy ?
06-23-2015, 08:56 PM
#3
Joined: Sep 2013
Posts: 180
Contrary to the TA article, iOS 9 isn't needed, nor is a dev licence. But a Mac and XCode 7 beta are needed. I'm on iOS 8.3. In Xcode 7 anyone can compile apps direct to their device.

The ones I listed were straightforward, I followed the guide linked to in the TA article. It's for gba but worked exactly the same for the others. You just have to get the source from GitHub or somewhere.

http://toucharcade.com/2015/06/10/emulators-ios-9-xcode-gba4ios/

Sorry, not sure how to link properly.

I tried retroarch but got a bunch of errors. I'm a noob to Xcode though, so maybe someone better than me could get it to work.

Last edited by Womble; 06-23-2015 at 09:01 PM.
06-24-2015, 10:43 PM
#4
Joined: Jan 2015
Posts: 6
Quote:
Originally Posted by Womble View Post
Apologies if there's already a thread about this that I've missed, or if this is the wrong forum. Or indeed if this is against the rules..

I've managed to install Gba4ios, provenance and MeSNEmu by compiling myself in XCode 7.

Just wondering if others have had success with any others, eg retroarch, mame etc
The same here.
I just can add to the list Gearboy and Gearsystem.
While I got built error with imame4all, retroarch, nds4ios, ppsspp.