★ TouchArcade needs your help. Click here to support us on Patreon.

App not updating on device.. only simulator

09-22-2009, 11:40 PM
#1
Joined: Jul 2009
Posts: 9
App not updating on device.. only simulator

I’m running into a little bit of a problem updating the app on my device…

I just made a couple of changes to my app and attempted to build and run the new version on my iPod Touch.

But now its not letting me update the app at all on the device!

The weird thing is I just updated my app 30 minutes prior to this current attempt with no troubles at all!

I tried restarting the computer…xcode… nothing. I’ve tried deleting all Fortune Girlz files on my device and restarting it too.


However when I run the Simulator the app updates just fine. The problem is only When I try running on my device. I’m still using 2.1.1 on my iPod touch which is updated to the most recent OS. But thats not the problem as it worked fine earlier today.

Something weird is going on!

Any thoughts? Its so weird how it stopped letting me update my app.

Cheers
09-23-2009, 12:23 AM
#2
Joined: Aug 2009
Location: San Francisco
Posts: 362
Send a message via Skype™ to micah
Deleting the app frmo your iPod and then clicking Build and Go should do it, that's weird. You can also try Build, Clean (or Clean All Targets) and then Build and Go again.

--=] Insurgent Games website | twitter [=-
Cryptose (TA) - Skeleton Key (TA) - Skeleton Key HD (TA link) - Aeropack (TA)
09-23-2009, 01:36 AM
#3
Joined: Jul 2009
Posts: 9
Cool! I did Clean all and everything is working great! Thanks for the tip :]