★ TouchArcade needs your help. Click here to support us on Patreon.

SDK version used in development

10-15-2009, 08:46 PM
#1
Joined: Oct 2009
Location: Middlesbrough
Posts: 67
SDK version used in development

What SDK version is everyone using to develop for the iPhone and iPod touch?

We have just upgraded to 3.1 and now we can only build for os versions 3.1 and 3.0 which is starting to cause alot of people to complain. Is there anyway we can continue to support the 2.5 OS or is this now not an option.
10-15-2009, 08:56 PM
#2
Joined: May 2009
Location: Palmerston North, New Zealand
Posts: 464
Supporting the 2.5 OS will be difficult since it doesn't exist

If you are wanting to support the 2.2.1 OS however change the base SDK in your project settings to iPhone Device 2.2.1 and this should give you access to the earlier SDK

Check out Sheepish, 100+ levels of puzzle fun! With sheep!
And more about us: www.pixelthismobile.com
plus+ id: Newtz
10-15-2009, 09:05 PM
#3
Joined: Oct 2009
Location: Middlesbrough
Posts: 67
Quote:
Originally Posted by PixelthisMike View Post
Supporting the 2.5 OS will be difficult since it doesn't exist

If you are wanting to support the 2.2.1 OS however change the base SDK in your project settings to iPhone Device 2.2.1 and this should give you access to the earlier SDK
Lol i was just guessing with the 2.5 part.
Ill give ago at changing the os number tomorrow, what do most other developers release there games for?
10-15-2009, 09:08 PM
#4
Joined: May 2009
Location: Palmerston North, New Zealand
Posts: 464
Check out this thread, it's currently active:

http://forums.toucharcade.com/showthread.php?t=29289

Consensus seems to be to still support 2.2.1 but it depends if you absolutely require any 3.x functionality.

Check out Sheepish, 100+ levels of puzzle fun! With sheep!
And more about us: www.pixelthismobile.com
plus+ id: Newtz
10-15-2009, 09:43 PM
#5
Joined: Jan 2009
Location: San Francisco, CA
Posts: 207
Quote:
Originally Posted by PixelthisMike View Post
Check out this thread, it's currently active:

http://forums.toucharcade.com/showthread.php?t=29289

Consensus seems to be to still support 2.2.1 but it depends if you absolutely require any 3.x functionality.
...which you may still be able to run on 2.2.1 by doing dynamic binding at runtime (e.g. MFMailComposeViewController) for some of the 3.0 capabilities

http://21gingerman.wordpress.com/200...ll-run-on-2-2/