★ TouchArcade needs your help. Click here to support us on Patreon.
App description: Manage your own magic store! Combine magic creatures called Mergimals and let them have babies. Can you breed the right Mergimal for each customer?

You have inherited a derelict and forgotten magic store. Can you manage to restore it to its former beauty? Find the right combination of Mergimals for each customer! Explore the secret districts around your store and keep discovering new Mergimals: some of them live in bubbling lava flows, others on snow-covered mountains. Catch them all, create new ones and become the most powerful magic store owner!

Mourkain's comments:


This is our new game Mergimals =D

- over 10000 procedurally generated Mergimals
- mix two Mergimals and see what happens
- take good care of your babies
- play colorful mini-games
- decorate your store and the baby-rooms
- explore 15 secret countries
- complete endless tasks

03-23-2017, 10:15 PM
#2
I start the tutorial and get to the visit of the first wizard, try to choose a Mergimal to give him and everything freezes. Anyone else having problems?

03-24-2017, 05:12 AM
#3
Joined: Jan 2014
Location: Ludwigsburg, Germany
Posts: 14
Hey Rooie1154,

we are sorry for this Bug. It's happening on newer iPads. A fix is already on the way. Thanks for playing Mergimals
03-24-2017, 09:00 AM
#4
Yay! I'm anxious to get a more complete view of the game. The artwork is charming.
03-24-2017, 04:51 PM
#5
Joined: Jan 2014
Location: Ludwigsburg, Germany
Posts: 14
The update is life. Should work now on all iPads
03-24-2017, 09:56 PM
#6
Alas, still not working for me. (iPad Pro running iOS 10.2.1)

Unless I'm not doing something right...but when the first customer comes to the store, I get to the page where I am supposed to choose a Mergimal to give away and nothing happens, no matter what I press on. The star in the task bar is glowing, the Mergimals are glowing, there is a spot glowing in the bottom dialogue box (the rounded space that looks a little like a dial) but nothing happens, no matter what spot I hit. Everything just seems to freeze and I have to get out of the game...only to start right back at the beginning.

Very frustrating.
03-25-2017, 03:21 AM
#7
Joined: Jan 2014
Location: Ludwigsburg, Germany
Posts: 14
Hmmm.. That's really strange :/
I will check this out!! Could you send me a Screenshot @ info@zunderfabrik.de ? That would be very helpful.

Cheers
03-25-2017, 05:36 PM
#8
Sent you a screen shot. Also, I just went into the game again...I got the the part of the tutorial where the customer enters the shop. By accident, I hit the map symbol, and suddenly there was the tutorial text overlaying some other text...and it all froze again. I realized, after I closed the game, that I should have taken another screen shot. I may see if I can replicate that...
03-25-2017, 06:05 PM
#9
Thanks so much to the developers for their help (and patience). Turns out that the update they sent out yesterday worked perfectly...my iPad just didn't let me know that the update was there to be triggered. (Sometimes it seems to load updates automatically, sometimes it lets me know updates are waiting, and sometimes...well, I guess it likes to keep them secret).

Working perfectly now!
03-27-2017, 07:59 AM
#10
Trouble launching

I also have a problem Mergimals. When I try to start up the app the loading screen takes a long while, then the moment im in the game, it crashes. I have tried to reinstall the app, switched my iphone (4s) on and off again, and starting the app multiple times. Nothing seems to work and I would really like to start playing. Hope someone can help me with this problem..