★ TouchArcade needs your help. Click here to support us on Patreon.

Games that require iPad air or newer

03-24-2017, 04:22 AM
#1
Joined: Nov 2013
Posts: 984
Games that require iPad air or newer

Do some of them work on iPad 4?By work i mean that they are playable.Sunless sea,construction simulator 2,oxenfree,star nomad 2,Eisenhorn Xenos,etc.

Last edited by Kenan2000; 03-24-2017 at 04:25 AM.
03-24-2017, 06:48 AM
#2
Quote:
Originally Posted by Kenan2000 View Post
Do some of them work on iPad 4?By work i mean that they are playable.Sunless sea,construction simulator 2,oxenfree,star nomad 2,Eisenhorn Xenos,etc.
There should be a reason why they have put this requirement, that makes them lose sales from those devices.

It should work, but it is not going to be a smooth experience in most cases.