★ TouchArcade needs your help. Click here to support us on Patreon.

Earthworm Jim App

10-26-2009, 02:12 AM
Joined: Oct 2009
Posts: 7
Earthworm Jim App

Hey All,

I would really appreciate if someone could help me on this. I downloaded Earthworm Jim yesterday, and when I first played it, it looked great. It started once on my ipod (right after I downloaded it) and so far I haven't been able to get it to start again. The screen just goes black and then it returns to the home screen. I have no idea what the problem is. I have the new 3G 64 GB touch, and it still has about 8 GB's of memory left. My itunes and ipod have all the newest software.

After it stopped working, I tried resetting my ipod, deleting the game and re-downloading it, and then just resyncing it a couple times, but still nothing works.

I'm about out of ideas.. I've also tried deleting a few apps, adding them again and seeing if that triggers anything but no.

Any advice would be great, but I just think it's ridiculous that I just paid $7 for something that doesn't even work.

10-26-2009, 02:40 AM
Joined: Jul 2009
Location: Melbourne, Australia
Posts: 2,585
Firstly, welcome to TouchArcade!

If you still can't get it working and you have the iTunes receipt, report a problem to Apple to get a refund.

Other than that, have you tried a full restore of your ipod?

BTW, this is in the wrong section of the forum, it should be in Games Discussion
10-26-2009, 03:12 AM
Joined: Sep 2009
Posts: 63
Hi, I had this problem earlier on my iPhone 3gs, and it settled itself after a redownload from the device (not iTunes) and a hard restart (hold power and home until it shuts off and the apple logo comes on). It's a great game though besides some slow startup issues. Good luck and let us know how it goes!
10-26-2009, 10:46 AM
Joined: Oct 2009
Posts: 7
Thanks Guys.. I'll try that out. I really want this app to work!
10-26-2009, 04:06 PM
Joined: Apr 2009
Location: Sacramento, CA
Posts: 3,154
Hey BearsJeep, I'm having the same problem as you. EWJ actually worked fine the first couple days I had it, booted it up probably about 5 or 6 times before the app stopped working. Other people are having the same problem, too. I've read on the Gameloft forums that "an update is being worked on", so they're aware of the problem. But if it's anything like Blades of Fury (another Gameloft game that is having the exact same problem) then it might be quite a while if they ever even DO fix it. I'm very disappointed, especially since EWJ worked for a while and I got a taste of how awesome it is. Anyway, just know that you're not alone and there's quite a few other pissed off Gameloft customers that hope this all gets worked out quickly.

Here's a couple links that might help:

Gameloft Contact Page

iPhone/iPod touch Problems topic thread in Gameloft Forums

Blades of Fury Problem topic thread in Gameloft Forums

I'm awaiting Gameloft approving my forum membership, but once that's done I'm going to post in these threads and make a dedicated "EWJ doesn't work" thread. I've also sent them an email through there contact portal. I'm not expecting much, except maybe a canned response, but if we can get enough people together to start bugging them then maybe they will put the fix they're working on into high gear or something. I'm just as bummed as you about not being able to play mah gamez!!!
10-27-2009, 03:12 AM
Joined: Apr 2009
Location: Sacramento, CA
Posts: 3,154
Sorry to double post, but here is my response from Gameloft regarding the problems with EWJ and BoF:


In order to fix this problem, please follow these troubleshooting steps:

- Turn off your I-phone for one or two minutes.
- Turn on your I-phone and check if the application works properly

If it doesnít fix the problem, continue with these steps in order to perform a fresh installation:

- Delete the application from your I-phone.
- Turn off your I-phone for one or two minutes.
- Install the application on your I-phone.
- Reboot your I-phone.
- Check if the application works properly.

In case the problem stills present, probably the application wasnít downloaded properly on your iTunes, to solve this follow this troubleshooting steps:

-Delete the application from your iTunes
-Download the application again (ITunes will detect your previous download and will not bill this operation).
-Follow the steps to perform a fresh installation.

If this steps fix your problem, please let us know.

Best regards,

Dang Hung
Customer Service Representative

I explicitly told them I tried all of the above, and was looking to a real solution to my problem. I wrote them back, we'll see if they have any sort of substantial response next time. I doubt it though