★ TouchArcade needs your help. Click here to support us on Patreon.
App description: Riddlord ... Who is Riddlord? Why did he kidnap Spark, Jack Reed's son?
What secrets are hidden in the past of the famous serial killers hunter - Jack?
The answers to all these questions you will find in this wonderful 3D puzzle game ...
Seeker, in this game you have to fight with the immense consciousness and the world of Riddlord, in which everything is connected with the thread of thought and the pattern of liquid fire appears outward.
In pursuit of the lost there is nothing with which the sharp, as sword mind could not cope.
The first part of the game is in front of you.
You will have an amazing journey into the world of Riddlord, the world of a detective and mystic, secrets and inner alchemical transformations.
You have to solve a lot of different puzzles and secrets, some will be simple, and some will make you strain your minds, even the smartest ones.
After going through Jack Reed's way to the end, you immerse yourself in your own inner world, and you will come out renewed.
- Beautiful graphics
- Detective-mystical atmosphere
- Charming music
- Interesting puzzles of different levels (including those associated with the "Zodiac" and "Real Night Hunter")
- The plot is the common thread of two parts of this game, that will force you to focus on main characters fate and your own life
- Details of the world that help to better understand and imbue with the game
- The connection between the plot and the gameplay with the ancient mystical and philosophical systems, such as the I-ching and the tantric alchemy
To complete this game, you will need to mobilize your logic, spatial thinking, memory, observation, ingenuity, and assiduity. The fate of Jack Reed and his son is in your hands!
No chance to fail!

BigDich's comments:

11-30-2017, 05:14 PM
#2
Joined: May 2013
Posts: 315
Interesting. It almost reminds me of The Room, in a way.

12-01-2017, 11:34 AM
#3
Joined: Jan 2015
Posts: 179
I really try to like this game, but getting stuck in the first riddle confuses me a lot, cause i dont know if im dumb or the game has a big bug in the first scenario. I played all Room Games and The Davinci House so im normaly fast with this type of games.
Im stuck on the Riddle with the board with plates. And i have no clue how to arrange them. The game suggested me to do something with the candle but there is nothing to do. I pressed and swiped on every possible pixel. The knife also doesnt work on the candle. The plateboard suggested me that i need moonlight but i have no chance to blow out the candle.
Is this bugged or is the game overcomplicated?
Im a big fan of puzzles, but i like the feeling of progress in early stages. And being stuck without any other helpful clues is a nightmare.

Last edited by Ghostdog1; 12-01-2017 at 11:41 AM.
12-01-2017, 06:40 PM
#4
Joined: Dec 2016
Posts: 17
Think its bugged. I have got to a labarynth cylinder and it took forever to move the token around. Then it gets to the bottom and gets stuck right before exit every time.
Also if you minimise inventory on iPhone X its gone for good as far as I can tell
12-02-2017, 06:54 AM
#5
Joined: Jan 2015
Posts: 179
- please delete this comment box dear forum mods -

Last edited by Ghostdog1; 12-02-2017 at 09:49 AM. Reason: edit
12-02-2017, 03:20 PM
#6
Joined: Jul 2014
Posts: 15
Help

The cylinder code, the hints dont help, anyone know the 3 digit code?
12-02-2017, 11:28 PM
#7
Joined: Jul 2017
Posts: 4
3 digit code

Im stuck on the 3 digit code too. Anyone have any hints to help?
12-02-2017, 11:34 PM
#8
Game has problems...

Quote:
Originally Posted by Daerricx View Post
The cylinder code, the hints dont help, anyone know the 3 digit code?
Did you scratch off the green stuff from the apple's tag? That phrase there should help you...

As for the game itself, I honestly cannot give it more than 1 star.

- Controls are frustrating. Rotating a tile often spins the wrong way. Touch collision feels too tight (did they only test on desktop with mouse, or only use Apple Pencil or something??).
- Hints system is basically worthless. Each puzzle has a set of hints that are given in order. But the first few hints are usually stuff you'd have already figured out. Waiting 5mins or so for the hint to charge up is often just boring and tedious. Not exactly encouraging you to "find the solution". Seriously, if you've been trying for a while and you're stuck, then clearly you've done as much as you can figure out. And yeah, I know it's hard for the game to know what you've figured out, but hints were solved in Professor Layton. Just use their system, it's good and works.
- Some puzzles are SUPER abstract. Like, unbelievably so. The tiles puzzle is insanely difficult for what it is. I'll put this in spoiler, but anyone that's stuck on it should read:
So, you put the tiles in, because you have 16 and there are 16 slots. Not hard to figure out. (BTW, that's the first hint. Really dumb, I doubt anyone would be stuck there.)
Then, you can swap or spin tiles in place. So now it's like, "oh, there's a lot of permutations for how this can go.... hmm". Stare at it some more.
There are 3 numbers on each edge of the board. Good luck figuring out what they mean or how they help. Because I didn't, and neither did my partner nor other reviews online from what I can see.
Eventually, you'll either stumble upon a tile lighting up or get the hint for that (it's a few hints in, so it will take a while if you're waiting for hints to regenerate). OK, so NOW you have a starting point for this puzzle. Great, now it's actually possible to solve instead of being impossible to even start to solve.
Depending on the piece that lit up, you might be able to see some pattern it can join up with another tile. So go ahead and try them. At least now, it's just looking for the piece that fit and trying them all. You can take a systematic approach now, so the stress/frustration is lessened a lot.
Also, by this point you might also have another tile lit up from just sheer luck (because you were trying lots of tiles everywhere, there's a good chance another one lit up elsewhere on the board).
You'll eventually get a few more tiles lit up. And you probably still won't figure out what those numbers are for.
There's a clue about moonlight. No idea what that even means.
Completing this puzzle was not fun. Was basically a chore. It should start with at least one piece in the right place and lit up. Maybe, it automatically does that when you add the first bunch of pieces in, or maybe one just starts there like that. Either way, you can at least have a starting point to solve the puzzle. Right now, there's not even that and it's practically impossible for even intelligent people to properly solve it. Also, what the hell do the numbers mean?!?!

And then the next puzzle is the 2x2 Rubiks cube. If you like Rubik's cubes, you'll start to hate them because of this! I don't think this is a spoiler, but I'll hide it in case:
The problem is that a normal Rubik's cube has 6 sides and 6 colors. This one has 2 colors that are in some abstract pattern. So it's VERY hard to visualise or figure out how to get one piece to another. Maybe if you're a Rubik's cube pro it's easy. But that's a fairly low minority.
I'm not sure if the orientation of the cube itself mattered, or if you just have to get it "solved" and it would be OK. But it seemed like the orientation did matter when I was moving things around. It did look like the big blue piece lit up only when it was in a certain spot. What's dumb here, is that to properly "solve" this (from the game's perspective), you also need to spin the entire cube without just spinning a side. I couldn't find a way to do this, and the game didn't offer any hints if this was even possible (it needs to be for this sort of thing!).
In a 3x3 Rubik's cube, the centre tiles on each side never move. So you can at least orient yourself to those and move sides around accordingly. But on a 2x2, there's no static tile. So if the game really does force you to have the orientation of the cube correct, then that's FAR too hard with the current controls offered. Poor design, really bad game feel and just completely sucks any fun out of a "simple" Rubik's cube.
The WORST part about this puzzle, is I don't know anyone that has actually correctly completed it. Everyone (including myself), got frustrated with it and decided to restart the game hoping it would reset to the initial state. Instead, it resets to a state that is either solve or solved in 1 move! Yay, go through because of a bug (I think? maybe it was intentional??)...


And that's the end of the first chapter/room. I'll do the next room later today, and I'll write up more if my opinion changes (or is strengthened!). Right now, I strongly DO NOT recommend this. It's clunky, with puzzles that are just far too abstract to make any sense. Stick with The Room or Agent A for better puzzles and gameplay.
12-03-2017, 03:05 AM
#9
Joined: Jun 2010
Posts: 1,691
+1. The first puzzle is completely bugged. I can't move the pointer or token toward the exit once it reaches near the end of the labyrinth. The sound effect continues but nothing happens. The game is unplayable from this point on.

Quote:
Originally Posted by yoshihunter View Post
Think it’s bugged. I have got to a labarynth cylinder and it took forever to move the token around. Then it gets to the bottom and gets stuck right before exit every time.
Also if you minimise inventory on iPhone X it’s gone for good as far as I can tell

Last edited by y2kmp3; 12-03-2017 at 03:14 AM.
12-03-2017, 08:48 AM
#10
Joined: Jul 2017
Posts: 4
3 digit code

Thx for the clue about the wrapper to help with the 3 digit code needed for the capsule... except that I cant go back to read that clue now. Can you tell me what it is to kee me from having to go back and play the game all the way to that point or give me the clue from th wrapper to decipher?