★ TouchArcade needs your help. Click here to support us on Patreon.

Secrets of the mysterious island help

11-07-2009, 06:03 AM
#1
Joined: Mar 2009
Posts: 519
Secrets of the mysterious island help

Hi there.

Since 3 days the sequel to RTMI is out. It's called SOTMI and i found it as hard as the prequel:-(.

I'm still stuck at a point. The woman told me to look after the mysterious motor sound.. I've found something like a plane by some water. but then it's disappeared.

Can somebody help me what i have to do now?

Last edited by iSwiss; 11-07-2009 at 06:15 AM.
11-07-2009, 11:46 AM
#2
Joined: Nov 2009
Posts: 2
i'm blocked

you need to go where a monkey is sit down with a gun there is a tree in your back, climb it!
if you found how to make a antiseptic medicine, tell me
thank

11-07-2009, 12:04 PM
#3
Joined: Mar 2009
Posts: 519
Just solved my problem:-) thx u. Now i stuck on the same thing as you
11-07-2009, 12:36 PM
#4
Joined: Nov 2009
Posts: 2
don't know what to do, with antiseptic

help...
11-08-2009, 11:21 AM
#5
Joined: Mar 2009
Posts: 519
Just solved your problem.

Go to the snake and play with your Ocarina. Then the snail will disappear and you can pick some antisepticum.
11-09-2009, 09:33 AM
#6
gosh!! it`s sooo dificult...oh I`m too slow-witted for the game
11-21-2009, 03:01 AM
#7
Joined: Nov 2009
Posts: 1
help

I'm stuck painting the symbol that the monkey Leonard shows Jep. I have all the paint colors but nothing to paint with. The guide itsn't clear at all on this section. Any help?
11-28-2009, 03:32 PM
#8
I'm stuck at act II, the monkey is hungry after crossing the swamp yet he refuses to eat almost all the food I give to him!

Is this a glitch or what? D:
11-28-2009, 04:29 PM
#9
OK.... I figured out I could just give him ants, but.... now nobody wants to eat the oily fruit I need to complete the game! Is it a glitch or what? D:
11-28-2009, 05:45 PM
#10
Okay, there are sooo many bugs in this one it is ridiculous. You have blue berries that are dirty. You can wash them and give them to Jep. You can also go back to the monkey by the kiln and beg for a bunch of nuts. I have gotten across the swamp and found the distiller etc. However I need to find a way to get into the helicopter that is in the water. There are compartments on the side. Anyone know how you open them? I fixed part of one but it still is missing something. Also, if you fix the machine on the sand you get parts that you can put in the robot to make him give you maps etc.

Where the heck are the paints? Anyone know how to rescue the monkey up high? Where is a walk through?