★ TouchArcade needs your help. Click here to support us on Patreon.

Help with Chronicles of Inotia: A Wanderer of Luone

12-12-2009, 06:02 AM
Senior Member [Original Poster]
Joined: Nov 2009
Posts: 662
Help with Chronicles of Inotia: A Wanderer of Luone

So, I'm stucked in the quest that the Elf Priest gave me, I'm supposed to go to Toria to talk to some Gnome or sumthing like that, but all the Paths are Blocked, I've tried going by the Main Way in the Thieves' Hill (and unfortunately I entered the Thieves' Mansion and got raped) but the Way is blocked by some stupid Rocks, so I tried the Mine Route, it was also blocked by the stupid Rocks, so I went to Stone Tomb or sumthing like that and the Path is also blocked.

I don't know wtf I'm missing, and I really hate Minus Montains and Thieves' Hill, I bought 50 HP Pots and I spent about 35 in 2 travels wtf lol, and my Main Character died and I have his body but I can't rez him because I spent all my money on HP Pots lol.

We Rule ID: Sclerosis
Godfinger ID: Elkas
OpenFeint/Gameloft Live/Astro Ranch ID: Elkas
12-12-2009, 08:33 PM
Same here, have 5 or 6 open quests with main one going to the dwarf village and I'm stuck. The game has suddenly got very hard. Did you try the thieves house???
12-12-2009, 08:45 PM
Why dont you just ask in the main thread? A lot of people are asking their questions there. I would help you but I dont own the game...yet.

Playstaion Network: zachattacksox
Originally Posted by kijib View Post
my guns are so big i cant scratch my nose
Originally Posted by Skate View Post
Why would you hold firearms while scratching your nose?
12-13-2009, 01:55 AM
Joined: Jan 2009
Location: Finland
Posts: 329
Oh dear? What classes are you guys playing? I've played past that part on solo mage and rogue and was thinking this is too easy. Well, maybe I'm a bit too careful and slow with my actions. That's what you get for being too used to playing turn-based RPG's.

Back on topic, I was a bit stuck as well on that phase before I figured out what to do. Outside the thieves' house there's a woman clad in white clothes. She'll give you a quest that you should accept. If she doesn't offer you a quest then you have some unfinished quests in the elf village. Can't remember which quest it is that's holding you back from receiving the thieves quest but I'm pretty sure it's some kill this and that quest.

The thieves' house quest is pretty simple actually. Just go through the thieves to the north. You can fight your way there or just evade them. Evetually you'll end up in a room with a solo thief boss. He's rather tough but hit and run method should take him down after a while if you can't fight him toe to toe.
For some more challenge you can take either east or west route from the main hall to find Great Bandits Antares and Jack who are quite a bit more powerful than the thief boss.
After dealing with the boss and picking up the lady's luggage you can get through the rock formations to dwarf village.

A few tips for mage and thief characters: As a thief you can stealth and go hide in the corner and regenerate there. Most of the time your natural regeneration is faster than that of your enemies so you won't have to use your potions.
For a mage you can always summon your pet and freeze the enemy if you can't get him to attack your pet otherwise. Then just start blasting away with your wand / fireball.
Also be sure to upgrade your weapons quite often. I had some troubles with my thief when I used weapons 10 levels below my own. I don't think armors are that important when compared to weapons. Maybe a different thing for Templar and a Knight.
Also those green ethers. To use them you have to unequip your item and then drag and drop the ether on it to get the benefit from it. Once you use them on an item you can't get them back and using another ether on an item with a green stat (another ether) it will overwrite the old one. You can use ethers on items with blue stats without overwriting them.
02-08-2011, 09:32 PM
Joined: Feb 2011
Posts: 1
Need Help

I am stuck on the quest where you have to find all of Haken's things, I found all of his gear except his sword. Where do I go to find it? it's quite far in the game as I am a level 41
06-22-2011, 07:54 PM
Haken's Things

The sword is somewhere in the middle of the map. You cannot NOT see it because it's right beside the path way. If it's not there, go outside, then go inside again. That should "reset" the whole map.