★ TouchArcade needs your help. Click here to support us on Patreon.

Iescaper Room 2 stuck!

01-05-2010, 02:54 PM
#1
Joined: Jan 2010
Posts: 3
Iescaper Room 2 stuck!

Hi all, I am in room 2 but a little stuck...
I have a star but have not found the 2nd one, I have a round orange and gold crest thing, I had a frog and a dagger but i used the dagger to open the floor and get the crest and I forgot what I used the frog for but I did something and it disappeared! I have not released the sword from the stand...its stuck, or got up on the shelf, I have not open the box on the floor but I have opened the puzzle in the cabinet (I dont know if i got lucky, i knew some and guessed some of the shapes and numbers and it worked i think?). I found the monkey puzzle under the hanging pot but have not opened it because something is missing. I didnt get the candle lit but i found a paper on the cabinet telling me to light it with a flint?).
After reading the forum I know i need to .....find the flint and light the candle, find another shuriken(star), remove the sword, get up on the shelf, solve the monkey puzzle?? Right?
Any help or hints....Ive been looking and the same stuff for days...

I read a post that says "Okay im in the second room and i pulled the board up and had two ninja stars and combined them".... I have gone over the floor fifty times now???

I also saw people write "tried brute force method"
Uh??? What? Pick at my Iphone??
07-27-2010, 03:23 AM
#2
Joined: Jul 2010
Posts: 2
very strange..
i'm on stage-2 .. and the box-code in the cabinet not working to me..
i'm tapping on the code box and nothing happening.. looks like a bug more then wrong step in the game..
there is trick to "operate" this box-code inside the cabinet? it's just not responding to me.. it's stays on the screen when the cabinet is open.. and not getting "inside" to ask for the code..... ?!?
07-27-2010, 03:43 AM
#3
Wrong section

わたしのねこはがこうえいきます。
私の猫は学校絵行きます。
07-27-2010, 03:56 AM
#4
Joined: Jul 2010
Posts: 2
Quote:
Originally Posted by MasterChief3624 View Post
Wrong section
didn't got you.. what i'm doing wrong?
07-27-2010, 05:57 AM
#5
Joined: Jun 2009
Posts: 10,505
Quote:
Originally Posted by juvaknin View Post
didn't got you.. what i'm doing wrong?
He meant you posted this thread in wrong forum section. Moved it to gaming discussion now.