★ TouchArcade needs your help. Click here to support us on Patreon.

OpenFeint 2.4 and 2.2.1 firmware

01-10-2010, 01:55 PM
#1
Joined: Nov 2009
Posts: 423
OpenFeint 2.4 and 2.2.1 firmware

2,4 feint use some services like "your position" so it's need 3.0+ firmware

but rly cut this options and use openfeint 2.4 on 2.2.1?
01-10-2010, 02:04 PM
#2
Joined: Dec 2009
Location: England
Posts: 7
Quote:
Originally Posted by YOMANx View Post
2,4 feint use some services like "your position" so it's need 3.0+ firmware

but rly cut this options and use openfeint 2.4 on 2.2.1?
I just don't understand you.

01-10-2010, 02:48 PM
#3
Joined: Nov 2009
Posts: 423
I mean Can I disable the options that require firmware 3.0..

and use openfeint 2.4 on 2.2.1 firmwares
01-10-2010, 03:00 PM
#4
Joined: Nov 2009
Posts: 10
Quote:
Originally Posted by YOMANx View Post
I mean Can I disable the options that require firmware 3.0..

and use openfeint 2.4 on 2.2.1 firmwares
You've got the OpenFeint source code...
01-10-2010, 04:16 PM
#5
Joined: Nov 2009
Posts: 423
deleted mapkit, works well
01-11-2010, 02:01 PM
#6
Joined: Jul 2009
Location: Zgrunturos and San Francisco
Posts: 595
You don't have to delete the mapkit. The trick to this is:

-Set your Base SDK in your app settings to 3.0 or higher
-Set your Deployment Target to 2.2.1
-In your target settings, for the linked libraries, set both MapKit and UIKit to be weak linked

Build for targets 3.0 or higher (not for 2.2.1). You can then load that build onto OS2.2.1 devices or higher.

Also, there is another caveat which we hit. If you do any form of casting to doubles, you'll run into a problem where, on a 2.2.1 device a lazy link will fail during runtime.

Go to where the basketball court and arcade go 1 on 1 with Hoops Madness!
01-13-2010, 03:48 PM
#7
Joined: Nov 2009
Posts: 423
Quote:
Originally Posted by mobileben View Post

Build for targets 3.0 or higher (not for 2.2.1). You can then load that build onto OS2.2.1 devices or higher.

but when i post it to review i can see message only for 3.0 users? or 2.2.1?


and can't understand it:
Also, there is another caveat which we hit. If you do any form of casting to doubles, you'll run into a problem where, on a 2.2.1 device a lazy link will fail during runtime.
01-13-2010, 06:48 PM
#8
Joined: Jul 2009
Location: Zgrunturos and San Francisco
Posts: 595
Quote:
Originally Posted by YOMANx View Post
but when i post it to review i can see message only for 3.0 users? or 2.2.1?


and can't understand it:
Also, there is another caveat which we hit. If you do any form of casting to doubles, you'll run into a problem where, on a 2.2.1 device a lazy link will fail during runtime.
I have no idea what you are trying to say, when you say

"when i post it to review i can see message only for 3.0 users? or 2.2.1?"

For the second part, it has to do with casting values to doubles. If you are not using doubles, then I would not worry about it.

Go to where the basketball court and arcade go 1 on 1 with Hoops Madness!
01-18-2010, 06:07 AM
#9
Hi YOMANx,

I followed your instruction to setup openfeint 2.4.2, it works fine on emulator and OS3.x device.

But when I install into OS2.2.1 device, I got the errors below:
<Program received signal: “EXC_BAD_ACCESS”.>

Do you have any suggestions to solve the problem? thanks!

*The game is using cocos2D 0.9.0 beta2
01-18-2010, 06:30 AM
#10
Joined: Nov 2009
Posts: 423
MapKit.framework, delete it in Frameworks.


ps try it on device! maybe it's lag with sim..

Last edited by YOMANx; 01-18-2010 at 06:36 AM.