App description: Retina Display owners: Look for Across Age DX

Epic journey through time for your iPhone & iPod touch.
"close enough to Hyrule to make Zelda fans feel right at home" (www.appletell.com)

Press Reviews:

RPGFan: "Across Age is a throwback to classic Action RPGs of the Super Nintendo and Genesis era... see how gorgeous the game looks"

Touch Arcade: "A great combination of fun combat and good puzzle variation allows Across Age to swiftly avoid the problems that many RPGs run into"

GamePro Magazine: "Across Age is unique and well-crafted, making it an easy contender for the title of "best action RPG on the App Store."

Kotaku.com: "retro charm and intriguing time-travel puzzles"


About:

Across Age rekindles the golden 16-bit era.Travel back through time and experience an all new oldschool 2D Action RPG! Across Age is the first Zelda like Action RPG to include real environmental puzzles, with the look of famous SNES and Genesis cartridge games.

The game offers 15 hours of classic 2D Action RPG gameplay, exciting story, anime cutscenes, a sweeping soundtrack and tons of diversified locations, monsters and riddles. Step into the role of 2 switchable characters: swordsman Ales and magician Ceska, each with own fighting and special skills that are needed to solve tricky puzzles and successfully battle fierce monsters. This cooperative element is one of the key features of the game. Another key feature is the possibility to travel through time and revisit places, enabling exciting events and riddles.

Find spike shoes to walk on ice, burn bushes to open new paths, find friends who help you on your journey.
Let the adventure begin!

jak56's comments:
yep. it's out

03-19-2011, 06:25 PM
Joined: Mar 2011
Location: San Fran
Posts: 3
Final Boss help pleasee

This has probably been asked before but I really don't know how to defeat him. . I have tried everything and I just don't know how to even damage him!
03-20-2011, 12:17 PM
I now have two clocks and am heading to the north, where a mountain is. But there are stones in my way. How do i remove them?

Playing: Assassins creed 2, GTA: CW, Frogatto, Tilt toLive, Zen Bound 2, Aerox, Ninjatown Three of doom, Trundle
Most Wanted: ...

03-21-2011, 09:36 PM
Joined: Mar 2011
Location: Bermuda Triangle
Posts: 115
The game offers 15 hours of classic 2D Action RPG gameplay, exciting story, anime cutscenes, a sweeping soundtrack and tons of diversified locations, monsters and riddles. Step into the role of 2 switchable characters: swordsman Ales and magician Ceska, each with own fighting and special skills that are needed to solve tricky puzzles and successfully battle fierce monsters.
03-22-2011, 09:37 AM
I m just at the beginning but how can I use those both people for climbing ove a wall ???

Thanks for your help.
03-22-2011, 11:43 PM
House of clock

Where is the house of clock and how to go there, please tell me ,i cant find ToT.
03-23-2011, 12:06 PM
Quote:
Originally Posted by Annabel View Post
I guess I am stuck here as well. I defeated the Spider Boss (and if I return to where he was, he is still gone), but the gate is down and I am getting the same message about a switch in the ruins. What I am missing?

Thanks!

Hi I have the same problem. I defeated the spiderboss, got out ofbthe seabed cave, went to the entrance of the ujammie ruins, but the fence is preventing me from entering... I wandered around looking for a switch in the seabed cave 3 times now... What prevents me from entering the ruins beside of killing the spider boss (which i did). I even reloaded a previous saved game, killed the boss again because I thought it could have been a bug, but no success...

Thanks in advance, wonderfull game btw!!
03-23-2011, 02:06 PM
Quote:
Originally Posted by iSwiss View Post
I now have two clocks and am heading to the north, where a mountain is. But there are stones in my way. How do i remove them?
Talk to a man name belladonna. He tell u to see "Violet", u can find her(or him) by leave out with northeast exit and u can arrive violet house by use "icewave" skill.
03-23-2011, 04:16 PM
Quote:
Originally Posted by Marquessa View Post
Hi!

I actually completed the Ujammi Beach part of the game but wanted to get back to the fisherman however, I can't <SPOILERS> because all the water is drained out of the beach. Is there any to get back to the fisherman? I've tried to throw Ceska on the ledge but she can't get there...</SPOILERS>

Any help would be appreciated
Same problem here. Seems quite silly of the developers not to alter this so Ceska can be thrown up there. Pointless having a side quest if you're prevented from completing it so early on in the game.
03-28-2011, 04:10 AM
I can't seem to find Dragon Cloak for Ceska... Where is it?
Is it in the House of Clocks, or somewhere else?
03-30-2011, 12:22 AM
I know this issue has already been brought up, but after scouring the thread for what seems like forever, I have yet to find my answer.

I'm stuck at the forest cave. I've been through dozens of times. The entrance blocked by four stones seems to be where I need to go, but I've just thrown Ceska onto the ledge and she can't move them. I have no idea how to get Ales up there and I have yet to procure the fireball spell.

Please help!

All times are GMT -5. The time now is 07:12 AM.