★ TouchArcade needs your help. Click here to support us on Patreon.

iPod Touch 3.1.2 to 2.2.1?

04-06-2010, 07:46 PM
#1
Joined: Oct 2009
Posts: 249
iPod Touch 3.1.2 to 2.2.1?

Hi,

in my upcoming game I will support firmware from 2.2.1 and up.

Problem is I haven't tested on 2.2.1 device and would like to do so. I can sacrifice my 1st gen iPod Touch for this, but it has 3.1.2 firmware.

My question is, can I somehow restore 2.2.1 on it for testing purposes?

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-06-2010, 08:07 PM
#2
Joined: Apr 2010
Location: USA
Posts: 152
Send a message via Skype™ to Regretgraal
are you jailbroken? ( iknow a lot from my friends) if so then if you can somehow perhaps find a saved version of 2.2.1 onlineand download it u culd restore it using openssh mostlikely ( the hard part wuld be finding 2.2.1)

04-06-2010, 08:11 PM
#3
Joined: Oct 2009
Posts: 249
Quote:
Originally Posted by Regretgraal View Post
are you jailbroken? ( iknow a lot from my friends) if so then if you can somehow perhaps find a saved version of 2.2.1 onlineand download it u culd restore it using openssh mostlikely ( the hard part wuld be finding 2.2.1)
thanks mate, but no, it's not jailbroken. I guess I'm out of luck then?

I wonder how other developers test against older firmware?

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-07-2010, 12:01 AM
#4
Joined: Jul 2008
Posts: 1,467
It can be done, but it takes a little work:

http://discussions.apple.com/thread....ageID=10638034

Hope this helps.
04-08-2010, 06:29 AM
#5
Joined: Apr 2010
Location: Europe, Latvia, Riga
Posts: 35
You can try testing in simulator 2.2.1 (if you installed that when installing Xcode)

a3team - founder
web: www.a3team.com
games in AppStore: Arco Pong, Avoid Maze, Sam the Fish
04-08-2010, 07:16 AM
#6
Joined: Oct 2009
Posts: 249
Quote:
Originally Posted by ihavenolife View Post
You can try testing in simulator 2.2.1 (if you installed that when installing Xcode)
For some reason there is no option for 2.2.1 on Simulator, but there is one for device?

Lowest for Simulator is 3.0

Is there an option somewhere to make 2.2.1 for Simulator available?

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-08-2010, 12:22 PM
#7
Joined: Feb 2010
Posts: 21
Quote:
Originally Posted by eJayStudios View Post
For some reason there is no option for 2.2.1 on Simulator, but there is one for device?

Lowest for Simulator is 3.0

Is there an option somewhere to make 2.2.1 for Simulator available?
Sounds like you set the "iPhone Deployment Target" to iPhone OS 2.2.1 or lower for the release build config only. Check your build settings for your "debug" configuration and set it to 2.2.1 also.
04-11-2010, 06:29 PM
#8
Joined: Oct 2009
Posts: 249
Quote:
Originally Posted by pocketjump View Post
Sounds like you set the "iPhone Deployment Target" to iPhone OS 2.2.1 or lower for the release build config only. Check your build settings for your "debug" configuration and set it to 2.2.1 also.
Thank you, but I only have this setting if I select 'Deployment', not Debug?

The way it is now I can build 2.2.1 for Device, but this gives me ~100 errors about GameKit not found etc., not sure how to fix this one.

But there is no 2.2.1 option for Simulator.

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-12-2010, 12:20 AM
#9
Joined: May 2009
Location: Spain
Posts: 137
GameKit and the other "cool" stuff is only available in firmware 3.X and superior, so if you want a 2.2.1 build you are unable to use gamekit or any other 3.x features
04-12-2010, 01:07 AM
#10
Joined: Oct 2009
Posts: 249
Quote:
Originally Posted by Eskema View Post
GameKit and the other "cool" stuff is only available in firmware 3.X and superior, so if you want a 2.2.1 build you are unable to use gamekit or any other 3.x features
That's right, but the idea is if user has 3.0 and up, he can then play on local network and doesn't than he/she can still play on same device in pass & play or single player mode.

Apple shouldn't have any problems with this me thinks?

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally