★ TouchArcade needs your help. Click here to support us on Patreon.

How many users on 2.2.1?

04-11-2010, 09:03 PM
#1
Joined: Oct 2009
Posts: 249
How many users on 2.2.1?

Hi,

do you guys know how many users are still on old 2.2.1 firmware?

I don't know what to do in my upcoming game, it uses GameKit which requires 3.0 for Bluetooth, but it also has multi player in 'pass & share' mode which can be played on 2.2.1.

What I'm afraid of that 2.2.1 users will get my game and leave 1 start reviews because they can't play via WiFi or Bluetooth (even if I say it in app description, but who reads those?)

Should I just release for 3.0 and stop worrying about it or is there still a lot of 2.2.1 users which would be stupid to ignore?

What would you do?

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-12-2010, 12:29 AM
#2
Joined: Jul 2008
Posts: 1,467
My opinion is that although most of the people who post in this forum have upgraded to 3.x, there is a large percentage of users who are still running 2.2.1. I think people should be smart enough to read the app's description before purchasing. It really makes no sense to leave a one-star review due to their own ignorance or laziness.

04-12-2010, 12:39 AM
#3
Joined: Mar 2009
Location: Oslo, Norway
Posts: 731
My guess is that the majority of people that are actually spending money on the App Store have long since upgraded to 3.0.
04-12-2010, 12:52 AM
#4
As far as I know, if you release for 3.0 you can't even download it on 2.2.1, so you won't have the one star rating problem.

-Angelo

Yobonja's latest game: Tap Party!
04-12-2010, 01:10 AM
#5
Joined: Oct 2009
Posts: 249
Quote:
Originally Posted by Yobonja View Post
As far as I know, if you release for 3.0 you can't even download it on 2.2.1, so you won't have the one star rating problem.

-Angelo
hmm, now I'm even more confused!

I thought that by setting Base SDK to 3.0 or 3.1 and Deployment Target to 2.2.1 means that it can be downloaded and installed on 2.2.1 devices, just that they can't use 3.0 features?

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-12-2010, 01:28 AM
#6
Joined: Jul 2009
Location: Zgrunturos and San Francisco
Posts: 595
Whether or not you want to deploy for 2.2.1 is up to you. We do. It represents about 8-9% of our user base, which was surprising to us. Even more surprising was that some of the 2.2.1 people were actually iPhone user!

I would think that the people are smart enough to figure out that 2.2.1 cannot support certain features.

As you mentioned, you can set the deployment targets for 2.2.1. There are some key things you need to do.

-You'll need to weak link certain frameworks that are 3.0+ specific
-You'll need to check the OS version and turn off (not via disabling buttons ... ie. gray out) the features in question. For example. We support in app purchases. For OS 2.2.1 devices, they never see the store icon.

Personally I think the overhead of supporting lower OS phones is not that big of a deal. But much of that stems from our game not requiring the higher SDK features. There are definitely some apps there where the features are critical.

Go to where the basketball court and arcade go 1 on 1 with Hoops Madness!
04-12-2010, 01:45 AM
#7
Joined: Oct 2009
Posts: 249
thanks mate, I'm thinking of doing same thing, but instead of graying out I will popup message saying 'OS version 3.0 and greater is required for multi player on local network'.

This way users will understand why certain features is not available.

Should be ok, what do you think?

Quote:
Originally Posted by mobileben View Post
Whether or not you want to deploy for 2.2.1 is up to you. We do. It represents about 8-9% of our user base, which was surprising to us. Even more surprising was that some of the 2.2.1 people were actually iPhone user!

I would think that the people are smart enough to figure out that 2.2.1 cannot support certain features.

As you mentioned, you can set the deployment targets for 2.2.1. There are some key things you need to do.

-You'll need to weak link certain frameworks that are 3.0+ specific
-You'll need to check the OS version and turn off (not via disabling buttons ... ie. gray out) the features in question. For example. We support in app purchases. For OS 2.2.1 devices, they never see the store icon.

Personally I think the overhead of supporting lower OS phones is not that big of a deal. But much of that stems from our game not requiring the higher SDK features. There are definitely some apps there where the features are critical.

Start your engines gentlemen, Vector Rally is out!

---
Twitter: http://twitter.com/VectorRally
04-12-2010, 01:51 AM
#8
Joined: Jul 2009
Location: Zgrunturos and San Francisco
Posts: 595
Quote:
Originally Posted by eJayStudios View Post
thanks mate, I'm thinking of doing same thing, but instead of graying out I will popup message saying 'OS version 3.0 and greater is required for multi player on local network'.

This way users will understand why certain features is not available.

Should be ok, what do you think?
I've learned to be cautious as we've been rejected for different things like accessing outside APIs as well as for disabling (graying out) buttons. But it is possible what you say, having a non-grayed out button that simply states the OS requirements. I've seen it done .... now just depends on if you want to roll the dice. I do think your approach is safer than graying it out...

I saw your other thread. I'm not in front of my Mac now ... but I think if you try to build for a lower version SDK, you will get a fail ... hence all your errors. This is because you're supposed to build using the Base SDK. But I believe with the simulator, but I could be wrong, it forces you to build using that SDK level too (2.2.1).

Go to where the basketball court and arcade go 1 on 1 with Hoops Madness!