★ TouchArcade needs your help. Click here to support us on Patreon.

Universal apps for ios 4.0?

06-20-2010, 11:29 PM
#1
Joined: Apr 2009
Location: Atlanta GA
Posts: 1,224
Universal apps for ios 4.0?

Out of curiosity, if you update your apps with some of the new stuff from ios4. Will it not work on ipad?

Even more general, will ios4 iphone apps work in 'emulator mode' on ipad?
06-21-2010, 11:51 AM
#2
Joined: Jul 2009
Posts: 317
Well it depends how you code your app, you can still compile against 4.0 but set your app's target to 3.2. Then it will still run on iPad, you just need to do checks in your code to make sure you don't try to run something on the iPad that isn't available since it's not running 4.0 yet and you have to weak link any 4.0 frameworks that are included in your app.