★ TouchArcade needs your help. Click here to support us on Patreon.

Targeting iOS4

07-08-2010, 06:42 PM
#1
Joined: May 2009
Location: Pittsburgh, PA
Posts: 302
Targeting iOS4

Hey developers,

Just wanted to get some feedback on anyone submitting apps just targeting iOS4? We did that and Trash of the World is getting featured as New and Noteworthy but the download numbers were not super fantastics.

So I'm just thinking many users haven't upgraded to iOS4 so they can't download. Is that a fair assessment?

Co-Founder/ IPhone Game Programmer
LeftRight Studios | LeftRight Studios Game Videos | Our iPhone Games: smackBOTS (Free) Top 100 App | KatchUp

Last edited by khangtoh; 07-08-2010 at 07:12 PM.
07-10-2010, 08:54 PM
#2
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by khangtoh View Post
Hey developers,

Just wanted to get some feedback on anyone submitting apps just targeting iOS4? We did that and Trash of the World is getting featured as New and Noteworthy but the download numbers were not super fantastics.

So I'm just thinking many users haven't upgraded to iOS4 so they can't download. Is that a fair assessment?
Yes, I know a number of people who haven't upgraded to 4.0. So yes, it would be fair to say that iOS 4.0 is not fully adopted by an overwhelming percentage of the iDevice community.

I have a question that is related to that and I hope that someone can help me out So I have the 4.0., 3.2. 3.0, and 2.2.1 SDKs, but on 4.0, I only have the option of baseSDKing (improper term?) 3.2 (which is what the iPad runs) or 4.0. I want to base target 3.0 (if I can), is there any way that I can do that?

Thanks guys!

07-10-2010, 09:16 PM
#3
Quote:
Originally Posted by WellSpentYouth View Post
I have a question that is related to that and I hope that someone can help me out So I have the 4.0., 3.2. 3.0, and 2.2.1 SDKs, but on 4.0, I only have the option of baseSDKing (improper term?) 3.2 (which is what the iPad runs) or 4.0. I want to base target 3.0 (if I can), is there any way that I can do that?
You want your Base SDK set to 4.0, and your Deployment Target set to whatever you want your minimum OS to be.
07-10-2010, 09:22 PM
#4
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by Little White Bear Studios View Post
You want your Base SDK set to 4.0, and your Deployment Target set to whatever you want your minimum OS to be.
Thanks Little White Bear! I have been using the iPhone SDK for almost 2 years now, but I never knew that. Sometimes you just have to laugh
07-10-2010, 09:27 PM
#5
Quote:
Originally Posted by WellSpentYouth View Post
Thanks Little White Bear! I have been using the iPhone SDK for almost 2 years now, but I never knew that. Sometimes you just have to laugh
Don't worry, you're not crazy. They only started making that the standard way of doing things a couple months ago.
07-10-2010, 09:36 PM
#6
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by Little White Bear Studios View Post
Don't worry, you're not crazy. They only started making that the standard way of doing things a couple months ago.
Even though Apple is now happy with me for using the iOS 4 SDK, Xcode is screaming bloody murder at OpenFeint. Ho hum, here we go again.
07-10-2010, 09:42 PM
#7
Quote:
Originally Posted by WellSpentYouth View Post
Even though Apple is now happy with me for using the iOS 4 SDK, Xcode is screaming bloody murder at OpenFeint. Ho hum, here we go again.
You need a newer OpenFeint SDK. It wasn't 4.0 compatible a month ago.
07-11-2010, 12:06 AM
#8
Joined: Oct 2009
Location: Ballarat, Vic, Australia
Posts: 416
Send a message via Skype™ to klicktock
And 3.0 is the new "minimum". If you set lower than that, Apple will reject your App.
07-12-2010, 11:27 AM
#9
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by Little White Bear Studios View Post
You need a newer OpenFeint SDK. It wasn't 4.0 compatible a month ago.
I just downloaded the latest OpenFeint SDK and put it in there (before I posted on this thread). All of my frameworks are red (which I assume means that they are only there in name), but some of the basic frameworks (like UIKit) aren't in the list when I select Add/Existing Frameworks.

Quote:
Originally Posted by klicktock View Post
And 3.0 is the new "minimum". If you set lower than that, Apple will reject your App.
Ok, good to know
07-12-2010, 07:30 PM
#10
Quote:
Originally Posted by WellSpentYouth View Post
I just downloaded the latest OpenFeint SDK and put it in there (before I posted on this thread). All of my frameworks are red (which I assume means that they are only there in name), but some of the basic frameworks (like UIKit) aren't in the list when I select Add/Existing Frameworks.
Sounds like your installation of the SDK may be wacky. I can see UIKit in the add frameworks list. In mine, I have a couple red ones, but if I hover over them, they say they are from the 3.0 SDK instead of 4.0.

Try making a sample project, and see if you can get it to work before trying to get OF to work.