★ TouchArcade needs your help. Click here to support us on Patreon.

iPhone: Why do some games require 2.1?

10-18-2008, 01:35 AM
#1
Joined: Aug 2008
Location: Cali-forn-i-a
Posts: 2,302
Why do some games require 2.1?

Im on 2.0.2 and cant update cuz im jailbroken. It seems most of the new apps require 2.1, is there a way to put them on my phone without upgrading? ( i would but 2.1 for 1st gen iphone hasnt been done yet) Also, please answer why these are in force.
10-18-2008, 01:38 AM
#2
Joined: Apr 2008
Posts: 2,438
Quote:
Originally Posted by Rocketman919 View Post
Im on 2.0.2 and cant update cuz im jailbroken. It seems most of the new apps require 2.1, is there a way to put them on my phone without upgrading? ( i would but 2.1 for 1st gen iphone hasnt been done yet) Also, please answer why these are in force.
I doubt it's possible. 2.1 introduced changes to the programming interface (API), so there's good reason why it would be required.

arn

10-18-2008, 01:40 AM
#3
Joined: Aug 2008
Location: Cali-forn-i-a
Posts: 2,302
Then ill just have to wait for 2.1 to be jailbroken *sigh*
10-18-2008, 07:02 AM
#4
Joined: Jul 2008
Location: Boston
Posts: 1,268
Quote:
Originally Posted by Rocketman919 View Post
Also, please answer why these are in force.
when programming, you can set which devices you wish the app to be allowed on, as well as test it on simulated versions of the OS
when signing the code, it is a 52 page detailed process...and it is easy to make a mistake on...thus simple backwards compatibility issues that can easily be corrected
10-18-2008, 08:13 AM
#5
Joined: Jul 2008
Location: Orlando, FL
Posts: 4,491
Quote:
Originally Posted by Rocketman919 View Post
Then ill just have to wait for 2.1 to be jailbroken *sigh*
Um... 2.1 firmware was jailbroken and added to both Pwn programs the day after it came out...

If you don't know how to use them you can PM me and I'll help you out

Oh, and to answer the question anyways: 2.1 changes the way games are run and code is handled (the extent of which I have no idea). That is why some 2.0 games have had issues on 2.1 firmware and why games built on 2.1 can't be played on 2.0
10-18-2008, 08:47 AM
#6
Im jailbroken on 2.0.2 just like you and I can't upgrade but If your jailbroken just go into cydia and install fwchanger. Open it up an there will be a custom firmware option. In the first typing field type 2.1. In the second typing field you need to type 5f136 then press set custom firmware. This doesn't change your firmware it just makes your phone think you are but it won't change in iTunes so you need to install the app from the mobile app store. Then just go into the mobile app store and install the 2.1 app that you want and see if it works. So far I've only done this with urban tycoon and that works so you'll just have to try it out. After your done installing the app don't even launch the app to see if it works go back to fwchanger and in the first typing field type 2.0.2 and in the second type 5c1. This will put you back on 2.0.2. If you don't it can really mess up your phone. Then when your firmware is normal again try the app out and see if it works.
10-18-2008, 09:11 AM
#7
Joined: Oct 2008
Posts: 104
^^^ that all sounds very messy. PwngeTool and QuickPwn now work on the latest 2.1 firmware so there really is no reason why you shouldn't upgrade to the latest firmware and then do the jailbreak.

2.1 jailbroken for 1st gen phone has been done - they did it a day or so after it came out and I know this for a fact since I have a 1st gen phone on 2.1 and it is jailbroken.
10-18-2008, 09:27 AM
#8
At first it's a little confusing but once you've done it it's easy.
10-18-2008, 12:52 PM
#9
Joined: Aug 2008
Location: Cali-forn-i-a
Posts: 2,302
Quote:
Originally Posted by Dimsum View Post
^^^ that all sounds very messy. PwngeTool and QuickPwn now work on the latest 2.1 firmware so there really is no reason why you shouldn't upgrade to the latest firmware and then do the jailbreak.

2.1 jailbroken for 1st gen phone has been done - they did it a day or so after it came out and I know this for a fact since I have a 1st gen phone on 2.1 and it is jailbroken.
so it does work? On modmyi they said that 2.1 for a 1st gen hasn't been done yet. So if I just create a new custom firmware bundle with 2.1 I should be good? What's the best way to update without losing my apps or songs?
10-18-2008, 04:08 PM
#10
Joined: Aug 2008
Location: NJ
Posts: 292
If you jailbroke with WinPwn, all that you have to do is grab a custom firmware from one of the torrent sites - hint: go to the bay of pirates torrent site - (that was created using Pwnage for the Mac; just make sure that you choose the correct one, as the file for first gen phones is different from the file for 3G phones) and load it to your phone using iTunes (click on shift+restore and choose the custom firmware file). I did that successfully on a first gen phone and on a 3G phone. You don't have to wait for a new WinPwn version! Just don't use QuickPwn, as it will update the baseband!


Quote:
Originally Posted by Rocketman919 View Post
Im on 2.0.2 and cant update cuz im jailbroken. It seems most of the new apps require 2.1, is there a way to put them on my phone without upgrading? ( i would but 2.1 for 1st gen iphone hasnt been done yet) Also, please answer why these are in force.