★ TouchArcade needs your help. Click here to support us on Patreon.

Can someone please tell me what I'm doing wrong on Blutrol? (PS3 Controller)

03-23-2013, 10:29 AM
#1
Can someone please tell me what I'm doing wrong on Blutrol? (PS3 Controller)

Okay, I'm new here, so please, bear with me. I have recently jail-broken my iPod Touch 4th generation, running ios 6.0.1, with evasi0n. I purchased the Blutrol application from Cydia, hoping to use my iPod as a portable console. The controller I wished to use with Blutrol, was the PS3 Controller. I plugged the controller into my PC, used the SixAxisTool, and changed the master to my iPods bluetooth address. On my iPod, I went into my settings, went into BTstack, and changed it to BTstack. Then I went into Blutrol, loaded a game picture, added my desired controls, then I connected my controller. I then loaded the game, but my controller didn't work. The controller showed that it was connected, but the button presses did nothing. I've noticed that BTstack randomly changes BTstack to none. The games I tried were Dead Trigger, Minecraft Pocket Edition Demo, Snes9x XE, and Asphalt 6. Can someone please tell me what I am doing wrong? Sorry if I did not include enough information, or if I posted this in the wrong section.
03-23-2013, 04:02 PM
#2
To add more information, I'm using an official Sony PS3 Controller. Any help is appreciated.

03-23-2013, 05:26 PM
#4
Thank you, but nothing is really working. The application page says iPod, but I'm doubting it will work. I haven't actually seen any videos of it. Dang, there goes $6.99.
03-23-2013, 05:39 PM
#5
*Update*
I've got the controller to kind of work on GBC AD +, but it's very glitchy, and renders the game unplayable by controller.
03-24-2013, 11:39 AM
#6
Joined: Jul 2009
Location: Kent, UK
Posts: 73
NOTE: You MUST leave the Blutrol app open for the games to work!!!

I found that Snes9x EX+ does not work for some reason.
Many of the '.EMU' emulators require you to turn the frameskip up to 1 or 2 (dependant on which emulator and what device) for the controller input to be smooth.
Many games that require a lot of processing power won't work well or at all, especially on older devices like the iPod touch 4th Gen. Try removing everything EXCEPT BLUTROL from the multitasking bar and try again. Also try it on other, less power-hungry games like Sonic 1 or 2. If it doesn't work at all on these then there's some kind of hardware issue.

Finally, I ALWAYS download an app or tweak for free from somewhere first to see if it works or not before purchasing (unless there's a lite version). You should do the same before paying $7 for something that you don't know works.
03-24-2013, 08:33 PM
#7
Thank you very much, I'm going to try this. Thanks for the advice at the end, I'll definitely do that next time I wish to purchase an app.
03-26-2013, 01:04 PM
#8
Blutrol PS3 Controller troubleshooting

After doing some digging around the internet, I was able to find that it seems there are quite a few other people experiencing problems with this particular app (and it's functionality when using a PS3 controller). I couldn't find too many forums where this problem is discussed, my research mostly involved looking at the comments section on YouTube videos for Blutrol with PS3 controllers. On the developer's Twitter page, someone does tweet asking about this issue, and the developer states that they are not able to reproduce that particular error.

The only troubleshooting I've really come across is to use Mobile Substrate in the SBSettings app to temporarily disable all other Cydia tweaks (except for Blutrol, of course) and to try setting up controls for the PS3 controller and play a game.

When I tried this, I disabled all other tweaks from Cydia, uninstalled the Blutrol tweak, reinstalled it, and tried setting up the controls again. Still no luck with using a PS3 controller with the Blutrol app.

I will say, though, that I have not tried SSHing into my iPad 3 and deleting all of the residual files left over after uninstalling my Blutrol app via the Cydia app store. I was able to notice that when I did uninstall and reinstall Blutrol, all of my settings from my previous installation were still there. So, I'm hoping that SSHing into my iPad and removing those files might help.

I'll most likely be trying it later tonight, and I'll post again later with results, but in the meantime, anyone else have any other troubleshooting ideas??

Oh, and I just wanted to include that, like the OP, I was also able to successfully connect my PS3 controller to the iPad. Blutrol app states that the controller is connected, and a single light on the PS3 controller shows that it's connected as well.
03-26-2013, 04:32 PM
#9
Update:

I went home on my lunch hour and tried SSHing into my iPad. Found a few files with "Blutrol" in the file name, deleted them, reinstalled Blutrol, and the settings (layouts, etc...) profiles were still there. Tried to play a game, no luck.

So, kind of stuck. Not sure what else I can try, but I'll keep looking.
03-31-2013, 12:59 PM
#10
Thanks a lot guys, the help here is great! (No sarcasm intended)