★ TouchArcade needs your help. Click here to support us on Patreon.

Updating to 3.2

09-02-2010, 11:59 AM
Joined: May 2010
Posts: 52
Updating to 3.2

I want to update my Ipod Touch from 3.1 to 3.2 to play the Epic Citadel.

Is there anyway I can do that? Itunes would only update to 4.0 which I believe completely whipes out my touch.
09-02-2010, 12:02 PM
Joined: Dec 2008
Location: Sacramento, CA
Posts: 4,568
None of that is true.

3.2 never came out for iPod touches. 3.2 is only for iPad.

You will have to upgrade to 4.0 on your touch to play this game.

And upgrading to 4.0 does not wipe anything off your device if you just do an update (and are not jailbroken). If you are jailbroken, you'll lose whatever you got from the jailbreak/cydia. Otherwise the update will just add the 4.0 stuff and leave all your apps and settings etc...
09-02-2010, 02:32 PM
Joined: May 2010
Posts: 52
Hmmm is there any way I can download epic citadel? iTunes doesn't allow my firmware. And os4 has battery issues that I don't want to deal with.

Thanks for the reply.
09-02-2010, 03:50 PM
Joined: Aug 2010
Location: Germany
Posts: 30
Send a message via ICQ to kralle777
Originally Posted by Sepharite View Post
And os4 has battery issues that I don't want to deal with.
No, my iPod Touch 2G runs fine with iOS4. I don't know why every says that he/she has battery issues. When OS 3.0 came out everyone was saying that too.
09-02-2010, 05:25 PM
Joined: Apr 2009
Location: Atlanta GA
Posts: 1,224
get 4.1 GM. It's suppose to have better battery life than 4.0
09-05-2010, 07:02 PM
Joined: May 2010
Posts: 52
I will consider updating to 4.0 sooner or later, but not at the moment since I already have most of the features OS4 includes.

so I suppose there is no other way to download off the App Store without updating my firmware? 3.1.3. It says I require 3.2 Iphone (which means I need 4.0)