★ TouchArcade needs your help. Click here to support us on Patreon.

OpenFeint 2.6.1 with Deploy Target of iOS 2.2.1

09-09-2010, 12:26 AM
#1
Joined: Sep 2009
Location: Vancouver, Canada
Posts: 977
Send a message via MSN to MindJuice Send a message via Skype™ to MindJuice
OpenFeint 2.6.1 with Deploy Target of iOS 2.2.1

I've got a project that was using an older version of OF before (OF 2.4.4) and was set to iOS 2.2.1 for the deploy target. That worked fine until I build with the 4.0 SDK. Now OF crashes as soon as I try to open it.

So I just dropped in OF 2.6.1, and suddenly got over 13000 compile errors in the OF code.

I found that switching the deploy target to 3.0 made all the errors go away. In addition, the crash that occurred in OF 2.4.4 doesn't happen, so that is good, but I don't know if requiring iOS 3.0 for an app that previously only required iOS 2.2.1 is going to go over well.

Is there any other way to make OF 2.6.1 compile cleanly with a 2.2.1 deploy target? OpenFeint technical support is nowhere to be found after repeatedly asking them for help in their forum.

Alternatively, is the iOS 3.x update available for free to iPod Touch users?

If existing users can just upgrade for free then I won't feel bad for setting 3.0 as the minimum.
09-09-2010, 12:37 AM
#2
Joined: Sep 2009
Location: Vancouver, Canada
Posts: 977
Send a message via MSN to MindJuice Send a message via Skype™ to MindJuice
To answer my own question, OF 2.6.1 does compile under iOS 2.2.1, but you need to do BOTH a "Clean All Targets", AND delete the build folder for your project.

I had just deleted the build folder before, but apparently that is not enough.

Weird, but good to know.

Still curious to know if iOS 3.x is available for download for iPod Touch users.
09-09-2010, 05:45 PM
#3
Joined: Jul 2009
Posts: 317
Just so you know, you can no longer submit binaries that target any iOS lower than 3.0
09-10-2010, 01:29 AM
#4
MindJuice,
Lukeca is correct. Apple no longer accepts Apps built for OS 2.x, so we removed support for the old OS a few versions ago. Terribly sorry that you hadn't heard back from my support team. Shoot me an email if you would. I'd like to pick your brain about your experience using OpenFeint.

Thanks for the continued support :-)

- Jason Citron
- Founding Craftsman at Hammer & Chisel
09-10-2010, 01:02 PM
#5
Joined: Sep 2009
Location: Vancouver, Canada
Posts: 977
Send a message via MSN to MindJuice Send a message via Skype™ to MindJuice
Quote:
Originally Posted by lukeca View Post
Just so you know, you can no longer submit binaries that target any iOS lower than 3.0
Yeah, that change actually just started to be enforced this week. I just had a new game approved with 2.2.1 on the weekend.

I've always tried to maintain OS 2.2.1 until now, but now Apple auto-rejects binaries that target anything before 3.0.