★ TouchArcade needs your help. Click here to support us on Patreon.

Background Advertising

12-08-2010, 11:17 PM
#1
Joined: Nov 2009
Posts: 5,146
Background Advertising

Dear TA,

The current background for your front page is making my iPhone stutter and lag horribly when I access it. I understand that the background is a part of the advertising that makes you money, but please consider that when it lowers the user's experience to such an extent, said user is just as likely to bookmark the main page of your forums as opposed to accessing them through the main page of your site until the annoyance is done with, thus, lowering your main page traffic and consequently its appeal to advertisers in the first place.

If it's simply a case of a technical mess-up, I hope it will get fixed as soon as possible. If not, and this is actually a normal and permanent effect of the background ad, perhaps you need to reconsider your strategy towards a better balance between income and user experience.

Cheers.
12-08-2010, 11:40 PM
#2
Joined: Nov 2010
Location: alea iacta est
Posts: 1,368
I think they said that they weren't going to optimize the website for the iPhone because they were focusing on making an app instead. But yes, this is one of many display issues when viewing the site from an iDevice.
12-08-2010, 11:57 PM
#3
Joined: Apr 2008
Posts: 2,438
The issue appears not related to the background image.

The background image adds like 56k to the page. It looks like all the other screenshots are causing the page to be too big. We also have some unoptimized screenshots in there. I'll see about alleviating it.

arn
12-09-2010, 01:07 AM
#4
Joined: Nov 2009
Posts: 5,146
Quote:
Originally Posted by arn View Post
The issue appears not related to the background image.

The background image adds like 56k to the page. It looks like all the other screenshots are causing the page to be too big. We also have some unoptimized screenshots in there. I'll see about alleviating it.

arn
Thanks for looking into it. Admittedly I'm only assuming it's the background, but the problem began right when it changed to what it is currently, and all pages on the site except for the main work just fine.
12-16-2010, 01:01 PM
#5
Joined: Dec 2008
Location: Central FL
Posts: 210
I exchanged messages with Eli about this issue. When I load the main page it bring Safari to a full out frozen beach-ball-inducing stop when the bar is 3/4 to 2/3 of the way across. Can't scroll, can't do anything. Total lock up. Only on this site, and only on the main page it seems. I've been told it wasnt due to advertising or the background but it's definitely something.

I'm on a 17" 2010 MBP i7 with maxed out ram and a freshly-reset version of Safari.

Interestingly, when I load the site in Firefox, I get a different issue. At the same load point the background still isnt loaded, and the load hangs on that last section. Everything else seems to load OK and at least the browser doesn't lock up, but the load bar tells everything I need to know. Something's hangin'. :-)


Thanks. I hope the issue can get resolved.